summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-1.4.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index c6506b1979cb..6926f5b70077 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1 +1,2 @@
DIST xca-1.3.2.tar.gz 897947 BLAKE2B b12cc95c908187d78304ce93111c89bb8e0dc01ecab37e0ad1bd78f84a90ed9f44afa4ac35d22185b7018e238b476e496fca3c2b3a240bf654d2e5160e784b11 SHA512 f0a9c4d47f0c20632f44364cc55293a7d2152772a746a72bc4a46622da4e48ae612bafe918c098a71c29cdfca8e6c03c27cf85a862ca0f356eddf061414c89b2
+DIST xca-1.4.0.tar.gz 940245 BLAKE2B 1f0c9d72b647fa803c2b6b6019b0b9828f37b1d38d89838ac6102d560b1c930c0f962e9064d984540b0c8e14d7546529af978673955555283afa1f089af7ce7c SHA512 b220adc7551cf853037c4f5ef0cdd8eef1dda44d0fde634cfde35605396b988452bdbc97a60459911f663d6d6977d426f27f47a46a482d1a30331ac06862c1c9
diff --git a/app-crypt/xca/xca-1.4.0.ebuild b/app-crypt/xca/xca-1.4.0.ebuild
new file mode 100644
index 000000000000..dfa838fead8d
--- /dev/null
+++ b/app-crypt/xca/xca-1.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="http://xca.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+}