summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/csound/csound-6.08.0.ebuild10
-rw-r--r--media-sound/csound/csound-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/media-sound/csound/csound-6.08.0.ebuild b/media-sound/csound/csound-6.08.0.ebuild
index a28fec3c57ee..8cc84ab08b7a 100644
--- a/media-sound/csound/csound-6.08.0.ebuild
+++ b/media-sound/csound/csound-6.08.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,7 +25,7 @@ REQUIRED_USE="
java? ( cxx )
linear? ( double-precision )
lua? ( cxx )
- python? ( cxx )
+ python? ( ${PYTHON_REQUIRED_USE} cxx )
"
RDEPEND="
@@ -82,12 +82,12 @@ DEPEND="${RDEPEND}
RESTRICT="test"
pkg_pretend() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
if use python || use test ; then
python-single-r1_pkg_setup
fi
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index 06c09139e74e..b67f5ec5779f 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,7 +31,7 @@ REQUIRED_USE="
java? ( cxx )
linear? ( double-precision )
lua? ( cxx )
- python? ( cxx )
+ python? ( ${PYTHON_REQUIRED_USE} cxx )
"
RDEPEND="
@@ -88,12 +88,12 @@ DEPEND="${RDEPEND}
RESTRICT="test"
pkg_pretend() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
if use python || use test ; then
python-single-r1_pkg_setup
fi