summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pypy-exe/metadata.xml1
-rw-r--r--dev-python/pypy-exe/pypy-exe-7.3.0.ebuild3
2 files changed, 1 insertions, 3 deletions
diff --git a/dev-python/pypy-exe/metadata.xml b/dev-python/pypy-exe/metadata.xml
index 89f86a0b2bea..cf6720905ca5 100644
--- a/dev-python/pypy-exe/metadata.xml
+++ b/dev-python/pypy-exe/metadata.xml
@@ -9,7 +9,6 @@
<flag name="low-memory">Build using PyPy with the engine configured towards low memory footprint.
This makes it possible to build PyPy using ~3.5G of RAM on amd64 and ~half of that on x86,
at the cost of lengthened build time.</flag>
- <flag name="sandbox">Enable sandboxing functionality</flag>
</use>
<upstream>
<remote-id type="bitbucket">pypy/pypy</remote-id>
diff --git a/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild b/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild
index cc4207c6f893..c8701c10e59c 100644
--- a/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild
+++ b/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}/${MY_P}-src"
LICENSE="MIT"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 +jit low-memory ncurses sandbox cpu_flags_x86_sse2"
+IUSE="bzip2 +jit low-memory ncurses cpu_flags_x86_sse2"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
@@ -108,7 +108,6 @@ src_configure() {
local args=(
--no-shared
$(usex jit -Ojit -O2)
- $(usex sandbox --sandbox '')
${jit_backend}