summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.38-r3.ebuild (renamed from dev-util/geany-plugins/geany-plugins-1.38-r2.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/geany-plugins/geany-plugins-1.38-r2.ebuild b/dev-util/geany-plugins/geany-plugins-1.38-r3.ebuild
index 5cd0d8af7efd..f74c64c1a2e0 100644
--- a/dev-util/geany-plugins/geany-plugins-1.38-r2.ebuild
+++ b/dev-util/geany-plugins/geany-plugins-1.38-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LUA_COMPAT=( lua5-1 )
-inherit lua-single
+inherit flag-o-matic lua-single
DESCRIPTION="A collection of different plugins for Geany"
HOMEPAGE="https://plugins.geany.org"
@@ -52,6 +52,10 @@ pkg_setup() {
}
src_configure() {
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#878529)
+ use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1
+
local myeconfargs=(
--disable-cppcheck
--disable-extra-c-warnings