summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/gtk-gnutella/Manifest1
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.1.11.ebuild87
2 files changed, 0 insertions, 88 deletions
diff --git a/net-p2p/gtk-gnutella/Manifest b/net-p2p/gtk-gnutella/Manifest
index c4da9c74f9dd..e635d3286ae9 100644
--- a/net-p2p/gtk-gnutella/Manifest
+++ b/net-p2p/gtk-gnutella/Manifest
@@ -1,2 +1 @@
-DIST gtk-gnutella-1.1.11.tar.bz2 19966423 BLAKE2B 38defd83e342751d86d0504846a0f80468a73d37faa25fd9c62a90da92306774fdf585c04e2729a7c9a68c206f67eaccfd483833ffe72b27cf08a5920e403115 SHA512 87d2d66b555180c0db7c360106377133b9e1f8ad8d28fc0f9a38498f3b4502a817650f9683cf92919b7d3a1b3602f7136143d2f1c920e10727576c703e233d07
DIST gtk-gnutella-1.1.13.tar.xz 19207704 BLAKE2B 4a11fd3f8bd7554e78a75b51b818e2e863edc328d07d0da4fce07e9a6eca7307dd66082dc70caf96e9e85d1d68ee1ef253a47ffb58cc9f33358a5d71b10782cb SHA512 14ff19a3f0bf55101570b4268cdd422defd2ccd112d80e9bafe2f6eb019b94c3c72763e67e2853d4446e68943355093c1279c6d67c101ca6d9b7f05ddd9ac7e0
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.1.11.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.11.ebuild
deleted file mode 100644
index 1afd56ee560f..000000000000
--- a/net-p2p/gtk-gnutella/gtk-gnutella-1.1.11.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils
-
-IUSE="nls dbus ssl +gtk"
-
-DESCRIPTION="A GTK+ Gnutella client"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-
-RDEPEND="
- dev-libs/glib:2
- sys-libs/zlib
- gtk? ( >=x11-libs/gtk+-2.2.1:2 )
- dbus? ( >=sys-apps/dbus-0.35.2 )
- ssl? ( >=net-libs/gnutls-2.2.5 )
- nls? ( >=sys-devel/gettext-0.11.5 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- strip-linguas -i po
-
- echo "# Gentoo-selected LINGUAS" > po/LINGUAS
- for ling in ${LINGUAS}; do
- echo $ling >> po/LINGUAS
- done
-
- default
-}
-
-src_configure() {
- # There is no option to turn off optimization through the build.sh
- # script.
- sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
-
- # The build script does not support the equivalent --enable
- # options so we must construct the configuration by hand.
-
- local myconf
-
- if ! use nls; then
- myconf="${myconf} --disable-nls"
- fi
-
- if ! use dbus; then
- myconf="${myconf} --disable-dbus"
- fi
-
- if ! use ssl; then
- myconf="${myconf} --disable-gnutls"
- fi
-
- if use gtk; then
- myconf="${myconf} --gtk2"
- else
- myconf="${myconf} --topless"
- fi
-
- ./build.sh \
- --configure-only \
- --prefix="/usr" \
- --cc=$(tc-getCC) \
- ${myconf}
-}
-
-src_compile() {
- # Build system is not parallel-safe, bug 500760
- emake -j1
-}
-
-src_install() {
- dodir /usr/bin
- emake INSTALL_PREFIX="${D}" install || die "Install failed"
- dodoc AUTHORS ChangeLog README TODO
-
- # Touch the symbols file into the future to avoid warnings from
- # gtk-gnutella later on, since we will most likely strip the binary.
- touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
-}