summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/nio4r/Manifest2
-rw-r--r--dev-ruby/nio4r/nio4r-2.2.0.ebuild40
-rw-r--r--dev-ruby/nio4r/nio4r-2.3.0.ebuild40
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-ruby/nio4r/Manifest b/dev-ruby/nio4r/Manifest
index 80a7a046f968..fb675458650a 100644
--- a/dev-ruby/nio4r/Manifest
+++ b/dev-ruby/nio4r/Manifest
@@ -1,4 +1,2 @@
DIST nio4r-1.2.1.gem 94208 BLAKE2B 229c1c690004444a6701ad765af26e592b9dbdb3646f155dc2114ea677b40097c0158c615efb25506c2ae59316e4ecdd7ec8747bf4f18a3ec2ca1be6bf028b85 SHA512 3136863955bd6f4d489955bae9baf2fb527447c0e71dade1a05402f3e7c8570bf1dd9b8335d70d7303ec4df0a236b13e4ede74ce9154be00a108afcd7c6b7f40
-DIST nio4r-2.2.0.gem 101888 BLAKE2B b860169c4fd4b3747af5327554b808c74585f509b69664da3da1558487a2f0119b9d1b56718c5301a13b4b4ccf8a55a8b661900d8992f40a8128ddbc638b0d87 SHA512 9a9acaede13da07894edb7012f593bd2132296f2130cc2529cfbbad421aaa1e7b144403c9812e6ac8429cf6bb9e8c7e746acd86f2061dedf4cc14fb10fdaa7fe
-DIST nio4r-2.3.0.gem 101888 BLAKE2B f2f3d1c962ae875ad68e5c4acd91b738a2a094f13293903ab1d65e6d2b32537bf624ccbf2524b897b9b3f1c4ac4161dc1f1758c267ed776a0b35f3dd3a994833 SHA512 266cb1cfbf62a0cdb130ccf7defa3f7142f1ddc4a45b6364197250abaa857b7177074eb7643bc9e005b30aa114c4337059092125734a3f13f3646a315eff2698
DIST nio4r-2.3.1.gem 101888 BLAKE2B 1891581eaa8659ed86f13e365664974ea55921e0107b7ce9757961cebe27f290995e90c17d375b35cf15245856c7c1d61fd05a332dc09032fffc1599bc2474ab SHA512 6e8fbc744f17b42a0a5c9f8f6db79ce3c9c0dbf6cb047f0b48faab813effc9f5dabe7405475a755bea9f0eb49037f6f26bdc6b8ff3fc7ab3bca61fc238e4eb6d
diff --git a/dev-ruby/nio4r/nio4r-2.2.0.ebuild b/dev-ruby/nio4r/nio4r-2.2.0.ebuild
deleted file mode 100644
index dfeaffaeab53..000000000000
--- a/dev-ruby/nio4r/nio4r-2.2.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A high performance selector API for monitoring IO objects"
-HOMEPAGE="https://github.com/socketry/nio4r"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# Note that nio4r bundles a patched copy of libev, and without these
-# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
-
-ruby_add_bdepend "test? ( dev-ruby/rspec-retry )"
-
-all_ruby_prepare() {
- sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
- sed -e '/extension/ s:^:#:' -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/${PN} extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/${PN}
- cp ext/${PN}/*$(get_modname) lib/ || die
-}
diff --git a/dev-ruby/nio4r/nio4r-2.3.0.ebuild b/dev-ruby/nio4r/nio4r-2.3.0.ebuild
deleted file mode 100644
index c894fe28db5f..000000000000
--- a/dev-ruby/nio4r/nio4r-2.3.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A high performance selector API for monitoring IO objects"
-HOMEPAGE="https://github.com/socketry/nio4r"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# Note that nio4r bundles a patched copy of libev, and without these
-# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
-
-ruby_add_bdepend "test? ( dev-ruby/rspec-retry )"
-
-all_ruby_prepare() {
- sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
- sed -e '/extension/ s:^:#:' -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/${PN} extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/${PN}
- cp ext/${PN}/*$(get_modname) lib/ || die
-}