summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch37
-rw-r--r--media-gfx/kxstitch/kxstitch-2.1.1.ebuild2
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch b/media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch
new file mode 100644
index 000000000000..70022fe9c8fa
--- /dev/null
+++ b/media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch
@@ -0,0 +1,37 @@
+From 9db3fcf9cd367681c0864238dc5009a604f3896c Mon Sep 17 00:00:00 2001
+From: Jonathan Riddell <jr@jriddell.org>
+Date: Wed, 27 Jun 2018 16:45:16 +0100
+Subject: fix build with Qt 5.11
+
+---
+ src/LibraryPatternPropertiesDlg.cpp | 2 ++
+ src/TextElementDlg.cpp | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/src/LibraryPatternPropertiesDlg.cpp b/src/LibraryPatternPropertiesDlg.cpp
+index 8d2e24c..c10da3f 100644
+--- a/src/LibraryPatternPropertiesDlg.cpp
++++ b/src/LibraryPatternPropertiesDlg.cpp
+@@ -11,6 +11,8 @@
+
+ #include "LibraryPatternPropertiesDlg.h"
+
++#include <QIcon>
++
+ #include <KConfigGroup>
+ #include <KHelpClient>
+ #include <KLocalizedString>
+diff --git a/src/TextElementDlg.cpp b/src/TextElementDlg.cpp
+index 4d88b1e..fb545d1 100644
+--- a/src/TextElementDlg.cpp
++++ b/src/TextElementDlg.cpp
+@@ -16,6 +16,7 @@
+ #include "TextElementDlg.h"
+
+ #include <QColorDialog>
++#include <QButtonGroup>
+
+ #include <KHelpClient>
+ #include <KLocalizedString>
+--
+cgit v0.11.2
diff --git a/media-gfx/kxstitch/kxstitch-2.1.1.ebuild b/media-gfx/kxstitch/kxstitch-2.1.1.ebuild
index 3e24a1c98c3e..e9ec0691e3f9 100644
--- a/media-gfx/kxstitch/kxstitch-2.1.1.ebuild
+++ b/media-gfx/kxstitch/kxstitch-2.1.1.ebuild
@@ -39,3 +39,5 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
!media-gfx/kxstitch:4
"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )