summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild (renamed from dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0-r1.ebuild)4
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.4.0.ebuild (renamed from dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.4.0-r1.ebuild)7
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.0.ebuild (renamed from dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.0-r1.ebuild)7
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.1.ebuild (renamed from dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.1.0-r1.ebuild)7
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.1.0.ebuild (renamed from dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.1-r1.ebuild)7
5 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0-r1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild
index e3d8971839e9..f253d611a1a7 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0-r1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild
@@ -36,6 +36,10 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.4.0-r1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.4.0.ebuild
index a46e8b513101..83138a10134a 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.4.0-r1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.4.0.ebuild
@@ -32,6 +32,13 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
python_prepare_all() {
# Needs to be run from a git repository
sed -i 's/test_contributors/_&/' \
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.0-r1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.0.ebuild
index d2ce9b4ddc17..4422a57b4a11 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.0-r1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.0.ebuild
@@ -32,6 +32,13 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
python_prepare_all() {
# Needs to be run from a git repository
sed -i 's/test_contributors/_&/' \
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.1.0-r1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.1.ebuild
index e2795baa8cd3..6819f5557b23 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.1.0-r1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.1.ebuild
@@ -32,6 +32,13 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
python_prepare_all() {
# Needs to be run from a git repository
sed -i 's/test_contributors/_&/' \
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.1-r1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.1.0.ebuild
index e2795baa8cd3..6819f5557b23 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.0.1-r1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.1.0.ebuild
@@ -32,6 +32,13 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
python_prepare_all() {
# Needs to be run from a git repository
sed -i 's/test_contributors/_&/' \