summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lxde-base/lxpanel/Manifest1
-rw-r--r--lxde-base/lxpanel/lxpanel-0.9.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/lxde-base/lxpanel/Manifest b/lxde-base/lxpanel/Manifest
index ebbf0e947d2f..827d4b35aa1e 100644
--- a/lxde-base/lxpanel/Manifest
+++ b/lxde-base/lxpanel/Manifest
@@ -1,3 +1,4 @@
DIST lxpanel-0.7.0.tar.xz 1479456 SHA256 bd010d13b1627335f45be1755f7f260dc439c2cfbce942bc36705fa2cffd0b53 SHA512 396147a24e852dd7288f99281116c797df4dbb1912925a6b4403ffe74bb8e3d821f7cd96965bedb2db9aff2d1ca3ae89be6e5712df04353a69a9cca5b03589aa WHIRLPOOL a5e4394e198b29bffa834b789bf34332e617837f0ebea0ea29bf595100c43aeb7d0a7698bbedb739dc058433462e1df661b41537f49904b77a4e7663360e45af
DIST lxpanel-0.8.1.tar.xz 1485612 SHA256 c657eb049a0f59e7b2d1ad6cb621c272833b765705c19089e48b3c248351b1e0 SHA512 cebad5e9399618adcc47ad0f2542bd57ce6cd707d65e9f1f67e2a435607e91e948c14102eb5534bb8d60a964277ef98658ec8d7a0109121a4b4f6067b385e39d WHIRLPOOL 8f721f6d81a89f35a2a44e33e0faaca2a1e956d1b826a11f85e3586721238c92a299336c35dcd876d3e98a26691255d9d8118828d5dbd124fd5ffc9367d23629
DIST lxpanel-0.8.2.tar.xz 1488548 SHA256 516ac4c83494ee99b2a0d2466458519a9a2668272eeff6d2162af3683b634104 SHA512 abab9175c4a4e591a33c39fbc41754e458eea60c79f5a40d56848338b910a867bafed09b4d1f2596a588beb79bfb5efe54c798ff5f7b0ee74f6245a1b0417918 WHIRLPOOL d9ffdb25c206a63c4431d5c1d4aa2563aaa884c9fa4d18d6215e4eb66899d2760895847452ccaf246051aafbd8353b4aa5e630ba46f5f6aff85a3f8d5ae3845d
+DIST lxpanel-0.9.2.tar.xz 1514748 SHA256 e66811a014cde9cb4882aeae48e96125729b9b1ec40e909031f4520eaa020cf1 SHA512 d7b5733345233a44466b6786133b8c3f3c9217a5195654b8dde3447a0dfc198082d991b2bc0cc60ddf200ebb95d636885b36d5642c11f4cd913f66228c12bd3a WHIRLPOOL 3e546c09580f6a03ebc575835c58d3218bf59ca66c8d8ca357d922eee2c39376cf6e6c70594a0372049a5f24487374ce23b25c696743faed080f54a4f5871c71
diff --git a/lxde-base/lxpanel/lxpanel-0.9.2.ebuild b/lxde-base/lxpanel/lxpanel-0.9.2.ebuild
new file mode 100644
index 000000000000..4e24f70866b8
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.9.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE="+alsa wifi"
+
+RDEPEND="dev-libs/keybinder:0=
+ x11-libs/gtk+:2
+ >=x11-libs/libfm-1.2.0[gtk]
+ x11-libs/libwnck:1
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/libX11
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )
+ wifi? ( net-wireless/wireless-tools )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOC_CONTENTS="If you have problems with broken icons shown in the main panel,
+you will have to configure panel settings via its menu.
+This will not be an issue with first time installations."
+
+src_configure() {
+ local plugins="netstatus,volume,cpu,deskno,batt, \
+ kbled,xkb,thermal,cpufreq,monitors"
+
+ use wifi && plugins+=",netstat"
+ use alsa && plugins+=",volumealsa"
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf $(use_enable alsa) --with-x --with-plugins="${plugins}"
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+ default
+
+ # Get rid of the .la files.
+ find "${D}" -name '*.la' -delete
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}