summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/epoch/epoch-1.3.0.ebuild30
-rw-r--r--sys-apps/epoch/epoch-9999.ebuild26
-rw-r--r--sys-apps/epoch/files/epoch-1.3.0-fix-main.patch4
3 files changed, 26 insertions, 34 deletions
diff --git a/sys-apps/epoch/epoch-1.3.0.ebuild b/sys-apps/epoch/epoch-1.3.0.ebuild
index a37c2f912f6a..835ef3b7d1e0 100644
--- a/sys-apps/epoch/epoch-1.3.0.ebuild
+++ b/sys-apps/epoch/epoch-1.3.0.ebuild
@@ -1,33 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
-inherit epatch linux-info
+inherit linux-info
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity"
-HOMEPAGE="http://universe2.us/epoch.html"
-SRC_URI="http://universe2.us/${PN}_${PV}.tar.gz"
+DESCRIPTION="Init system, /sbin/init replacement; designed for simplicity"
+HOMEPAGE="https://universe2.us/epoch.html"
+SRC_URI="https://universe2.us/${PN}_${PV}.tar.gz"
+S="${WORKDIR}/${PN}_${PV/rc/RC}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-S="${WORKDIR}/${PN}_${PV}"
-
pkg_pretend() {
local CONFIG_CHECK="~PROC_FS"
[[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.3.0-fix-main.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.3.0-fix-main.patch
+)
src_compile() {
NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
@@ -68,7 +64,7 @@ pkg_postinst() {
elog ""
elog "Additional information about epoch is available at"
elog "${HOMEPAGE} and configuration documentation at"
- elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog "https://universe2.us/epochconfig.html which is useful reading material."
elog ""
- elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+ elog "Its author Subsentient can be contacted at #epoch on irc.libera.chat."
}
diff --git a/sys-apps/epoch/epoch-9999.ebuild b/sys-apps/epoch/epoch-9999.ebuild
index 007de0c5e28b..8022520e994c 100644
--- a/sys-apps/epoch/epoch-9999.ebuild
+++ b/sys-apps/epoch/epoch-9999.ebuild
@@ -1,32 +1,28 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
-inherit epatch linux-info git-r3
+inherit linux-info git-r3
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity"
-HOMEPAGE="http://universe2.us/epoch.html"
+DESCRIPTION="Init system, /sbin/init replacement; designed for simplicity"
+HOMEPAGE="https://universe2.us/epoch.html"
EGIT_REPO_URI="https://github.com/Subsentient/epoch.git"
+S="${WORKDIR}/${PN}-${PV/rc/RC}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS=""
-S="${WORKDIR}/${MY_P}"
-
pkg_pretend() {
local CONFIG_CHECK="~PROC_FS"
[[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
+)
src_compile() {
NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
@@ -67,7 +63,7 @@ pkg_postinst() {
elog ""
elog "Additional information about epoch is available at"
elog "${HOMEPAGE} and configuration documentation at"
- elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog "https://universe2.us/epochconfig.html which is useful reading material."
elog ""
- elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+ elog "Its author Subsentient can be contacted at #epoch on irc.libera.chat."
}
diff --git a/sys-apps/epoch/files/epoch-1.3.0-fix-main.patch b/sys-apps/epoch/files/epoch-1.3.0-fix-main.patch
index b158ae2e3396..f6df7680ac29 100644
--- a/sys-apps/epoch/files/epoch-1.3.0-fix-main.patch
+++ b/sys-apps/epoch/files/epoch-1.3.0-fix-main.patch
@@ -1,5 +1,5 @@
---- src/main.c.orig 2016-11-13 15:11:58.511021203 +0000
-+++ src/main.c 2016-11-13 15:12:21.096021358 +0000
+--- a/src/main.c
++++ b/src/main.c
@@ -1142,8 +1142,9 @@ static ReturnCode HandleEpochCommand(int
ShutdownMemBus(false); //We're done with membus now.