summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/rostest/Manifest1
-rw-r--r--dev-ros/rostest/rostest-1.14.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rostest/Manifest b/dev-ros/rostest/Manifest
index 5654fd5af45b..4bc29c3999ee 100644
--- a/dev-ros/rostest/Manifest
+++ b/dev-ros/rostest/Manifest
@@ -4,3 +4,4 @@ DIST ros_comm-1.13.2.tar.gz 1007451 BLAKE2B 8963267f7cbe625a1160c3d8bdf34dd9c0b1
DIST ros_comm-1.13.4.tar.gz 1013412 BLAKE2B 0f5a33ae9c5c3bd3c04e26903c4ee7dff2d30f896fbca620100b9db58e8a338cbe79a9305dedb9e8d6f4a9c13b823e5016178db228bb2661eadb6864e20fad40 SHA512 6057afa5b79da661ecdc60459462fe09a7a90b5e43cbf6c5bdfa4095f07e00356eb13c9cab460b91a0c84b789ccf0753c09666ad24fb4b3aec967cb407cf81ce
DIST ros_comm-1.13.5.tar.gz 1027857 BLAKE2B ed2611179bc7f84bf0b9cde1336474a3bc4c3980ebf97241910123abd430a48ae0636a6ddfb6c191bea2905454644c7ec340e26049d8faddca39783bef13d60b SHA512 91af2de897851061eda140d6c96ec88171f1fd1cd7549b6df1ac570e066603c7bb721a58cb19487657387753433d67ad22421408a237d1ffb5ea580c0cf3eeb3
DIST ros_comm-1.13.6.tar.gz 1047870 BLAKE2B 874e31faa1a6a77292dab4b7fa64ed13a1f1f63f76512ea351e53bd14ce87662cea5c648e48c3c16668104129cc5eb172bc8f381516bdba676c7212f1acbaaf9 SHA512 382e81847141ab95462fc84a8215b945af995d29f9c0d507665e22faaf79aee9789950546ca7737bd40059f3ed1ecd284ff11bd3e6f1732f3c47a433c5d25155
+DIST ros_comm-1.14.2.tar.gz 1044745 BLAKE2B 1a5d47a4c6682c7a629d9d84be121a5eafcfc16621dec9a9ab9b57c2c7f9070f0007e15492ee44d86e1879351fae20bb9a759093424dd22ae7d44ae0f28e00e1 SHA512 8cece09572dc6b94a42eb49537cbcddbb954f70df01dc7ac9bd8aba17f53207b86afd8ccff81d929eca33bb9642ad7c530835d3f43471de497611940edae4777
diff --git a/dev-ros/rostest/rostest-1.14.2.ebuild b/dev-ros/rostest/rostest-1.14.2.ebuild
new file mode 100644
index 000000000000..10f35c044f10
--- /dev/null
+++ b/dev-ros/rostest/rostest-1.14.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Integration test suite based on roslaunch that is compatible with xUnit frameworks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_USEDEP}]
+ dev-ros/rosmaster[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? (
+ ${RDEPEND}
+ dev-cpp/gtest
+ )"