summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/csscomplete/Manifest1
-rw-r--r--app-vim/csscomplete/csscomplete-1.0.ebuild21
-rw-r--r--app-vim/csscomplete/metadata.xml11
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/csscomplete/Manifest b/app-vim/csscomplete/Manifest
new file mode 100644
index 000000000000..c3827994f97e
--- /dev/null
+++ b/app-vim/csscomplete/Manifest
@@ -0,0 +1 @@
+DIST csscomplete-1.0.zip 18057 SHA256 e8a0b0356a986654d3d1acef11da99dd91f01c80f49ccd6f15b78a0c31735a55 SHA512 63b8b9a31d09ba6ce8195b524df5785cf5da73db7b487b68bba291fcfb62af0ea8e595f1aed73d657b8343775bacca056185dae9fc22d0dbcad1596653f94a81 WHIRLPOOL 7e3c19a05e0fbcc7e82be2b0cd44e71b7fc573468f54c701e49889cee2cb9101091aaeaf9481f1ce409a592dfd56185a84871ed62b26b63dca848be4cdbda3e9
diff --git a/app-vim/csscomplete/csscomplete-1.0.ebuild b/app-vim/csscomplete/csscomplete-1.0.ebuild
new file mode 100644
index 000000000000..387cd0b2f81b
--- /dev/null
+++ b/app-vim/csscomplete/csscomplete-1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: CSS 3 omni complete function"
+HOMEPAGE="https://github.com/othree/csscomplete.vim"
+SRC_URI="https://github.com/othree/${PN}.vim/archive/${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}.vim-${PV}"
+
+src_compile() {
+ rm -v config.mk || die
+}
diff --git a/app-vim/csscomplete/metadata.xml b/app-vim/csscomplete/metadata.xml
new file mode 100644
index 000000000000..6c8987e6f46f
--- /dev/null
+++ b/app-vim/csscomplete/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>