summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/opencv_tests/Manifest1
-rw-r--r--dev-ros/opencv_tests/metadata.xml5
-rw-r--r--dev-ros/opencv_tests/opencv_tests-1.11.8.ebuild32
-rw-r--r--dev-ros/opencv_tests/opencv_tests-9999.ebuild32
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ros/opencv_tests/Manifest b/dev-ros/opencv_tests/Manifest
new file mode 100644
index 000000000000..ae2c9da2cd55
--- /dev/null
+++ b/dev-ros/opencv_tests/Manifest
@@ -0,0 +1 @@
+DIST vision_opencv-1.11.8.tar.gz 80160 SHA256 0cf0934d4d9bd91e966afc2f25a4e54646016b6628f4fe58e81faee0c58c88c2 SHA512 55ca2554a3736bd5102bfef14562a6bc341d13eb098fbb7d8d050c90b5d397820791aed54a3697f5084a1b629d959c7abc24172a8efbdfc65490ebdbcb548c77 WHIRLPOOL 8b2b9f4968618258ebd6b2d6d0674ca9c24ed5e7d1adcc4cbbf769e13206017ea06fe5172277a19d67c73c88066270a2e259743ee1b63e4cec7ce8508405b8d3
diff --git a/dev-ros/opencv_tests/metadata.xml b/dev-ros/opencv_tests/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/opencv_tests/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/opencv_tests/opencv_tests-1.11.8.ebuild b/dev-ros/opencv_tests/opencv_tests-1.11.8.ebuild
new file mode 100644
index 000000000000..9c9cf256119a
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-1.11.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}
diff --git a/dev-ros/opencv_tests/opencv_tests-9999.ebuild b/dev-ros/opencv_tests/opencv_tests-9999.ebuild
new file mode 100644
index 000000000000..9c9cf256119a
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}