summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/kexi/files/kexi-3.2.0-glib-2.68.patch40
-rw-r--r--app-office/kexi/kexi-3.2.0-r1.ebuild3
2 files changed, 42 insertions, 1 deletions
diff --git a/app-office/kexi/files/kexi-3.2.0-glib-2.68.patch b/app-office/kexi/files/kexi-3.2.0-glib-2.68.patch
new file mode 100644
index 000000000000..66f7c78d5b18
--- /dev/null
+++ b/app-office/kexi/files/kexi-3.2.0-glib-2.68.patch
@@ -0,0 +1,40 @@
+From 73d3fa8e7a1028c89b20c74f6444a76a722d8041 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Sun, 18 Apr 2021 11:47:30 +0200
+Subject: [PATCH] Include <glib.h> outside of the extern block
+
+This fixes the build with glib >= 2.68. It's caused by [1] and glib
+upstream did not want to include a workaround because the fixes
+downstream seem trivial [2][3].
+
+[1] https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1715
+[2] https://gitlab.gnome.org/GNOME/glib/-/issues/2331
+[3] https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1935
+---
+ src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h b/src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h
+index 31f48c171..56276e2d6 100644
+--- a/src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h
++++ b/src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h
+@@ -18,6 +18,8 @@
+ #ifndef _mdbtools_h_
+ #define _mdbtools_h_
+
++#include <glib.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+@@ -32,7 +34,6 @@
+ #endif
+ #include <ctype.h>
+ #include <string.h>
+-#include <glib.h>
+
+ #ifdef HAVE_ICONV
+ #include <iconv.h>
+--
+GitLab
+
diff --git a/app-office/kexi/kexi-3.2.0-r1.ebuild b/app-office/kexi/kexi-3.2.0-r1.ebuild
index 8daa08bfed19..9732672ee1a9 100644
--- a/app-office/kexi/kexi-3.2.0-r1.ebuild
+++ b/app-office/kexi/kexi-3.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -67,6 +67,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-missing-header.patch
"${FILESDIR}"/${P}-postgresql-9.12.patch
+ "${FILESDIR}"/${P}-glib-2.68.patch # bug 784974
)
src_prepare() {