summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.420.0.ebuild119
-rw-r--r--dev-perl/Apache-Test/Manifest1
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.420.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.420.0.ebuild
new file mode 100644
index 000000000000..14d91f4adb16
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.420.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHAY
+DIST_VERSION=1.42
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+need_apache
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.400.0-catfile-import.patch"
+ "${FILESDIR}/${PN}-1.400.0-phpclient.patch"
+)
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
+# Parallel tests seem to be bad.
+DIST_TEST="do"
+
+optdep_notice() {
+ local i
+ elog "This package has several modules which may require additional dependencies"
+ elog "to use. However, it is up to you to install them separately if you need this"
+ elog "optional functionality:"
+ elog
+ i="$(if has_version 'www-apache/mod_perl'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i www-apache/mod_perl"
+ elog " - Running Perl code natively in Apache via"
+ elog " Apache::TestHandler, Apache::TestReportPerl, or Apache::TestSmokePerl"
+
+ if use test; then
+ elog
+ elog "This module will perform additional tests if these dependencies are"
+ elog "pre-installed"
+ fi
+}
+src_test() {
+ optdep_notice
+ echo
+ local MODULES=(
+ "Apache::Test ${DIST_VERSION}"
+ "Apache::Test5005compat 0.01"
+ "Apache::TestBuild"
+ "Apache::TestClient"
+ "Apache::TestCommon"
+ "Apache::TestCommonPost"
+ "Apache::TestConfig"
+ "Apache::TestConfigC"
+ "Apache::TestConfigPHP"
+ "Apache::TestConfigParrot"
+ "Apache::TestConfigParse"
+ "Apache::TestConfigPerl"
+ "Apache::TestHarness"
+ "Apache::TestHarnessPHP"
+ "Apache::TestMB"
+ "Apache::TestMM"
+ "Apache::TestPerlDB"
+ "Apache::TestReport"
+ "Apache::TestRequest"
+ "Apache::TestRun"
+ "Apache::TestRunPHP 1.00"
+ "Apache::TestRunParrot 1.00"
+ "Apache::TestRunPerl 1.00"
+ "Apache::TestSSLCA"
+ "Apache::TestServer"
+ "Apache::TestSmoke"
+ "Apache::TestSort"
+ "Apache::TestTrace 0.01"
+ "Apache::TestUtil 0.02"
+ "Bundle::ApacheTest ${DISTVERSION}"
+ )
+ has_version "www-apache/mod_perl" && MODULES+=(
+ "Apache::TestHandler"
+ "Apache::TestReportPerl"
+ "Apache::TestSmokePerl"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl_rm_files t/more/02testmore.t t/more/04testmore.t
+ perl-module_src_test
+}
+pkg_postinst() {
+ use test || optdep_notice
+}
diff --git a/dev-perl/Apache-Test/Manifest b/dev-perl/Apache-Test/Manifest
index 4f032788ac96..b219cb3ffb26 100644
--- a/dev-perl/Apache-Test/Manifest
+++ b/dev-perl/Apache-Test/Manifest
@@ -1 +1,2 @@
DIST Apache-Test-1.40.tar.gz 151801 BLAKE2B 0ec57b0a8a0fafc8d10409a3cd02308da67bd6766caa71bfb525ef49832545c811281a987a5237be236a3a581fcf8311785d0bff8d283db2c52f08d11cd2bda1 SHA512 f48a1b93c4d61181670ec59bb8bb2231122b22ec9725d8899a3b2f82d2918fdc48a09494c2f45b0e6a603546481892a948eac3494e06c8eb219a9213e1faadb8
+DIST Apache-Test-1.42.tar.gz 153621 BLAKE2B 570c61e4b5f17c97376ba9f4ab3cde0b14df367f06b665e31dba9c6675972ad4d1bebe46b08416b0f4749d723a6b909430c9bdd1e5d3b1c6b21d209635f1236a SHA512 ecd78dde1b0db562d591990bcd50fe880d724dce9bfb20dceea3a51b81abd89d40889857e5e7714b586a093ad6f101dfd79c6aa33d63c906c41c532305b6584c