summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/pulseeffects/files/patch-4.7.2-gcc10.patch32
-rw-r--r--media-sound/pulseeffects/metadata.xml5
-rw-r--r--media-sound/pulseeffects/pulseeffects-4.7.2-r1.ebuild (renamed from media-sound/pulseeffects/pulseeffects-4.7.2.ebuild)4
3 files changed, 36 insertions, 5 deletions
diff --git a/media-sound/pulseeffects/files/patch-4.7.2-gcc10.patch b/media-sound/pulseeffects/files/patch-4.7.2-gcc10.patch
new file mode 100644
index 000000000000..fb8080dd823a
--- /dev/null
+++ b/media-sound/pulseeffects/files/patch-4.7.2-gcc10.patch
@@ -0,0 +1,32 @@
+From dbaea05da683f7bfcd7960c88b1b7d13379435c0 Mon Sep 17 00:00:00 2001
+From: Vasiliy Glazov <vascom2@gmail.com>
+Date: Tue, 24 Mar 2020 10:54:09 +0300
+Subject: [PATCH] Fix build with GCC 10
+
+This fix build error:
+```
+../include/plugin_base.hpp:10:25: error: expected ')' before 'tag'
+ 10 | PluginBase(std::string tag, std::string plugin_name, const std::string& schema);
+ | ~ ^~~~
+ | )
+../include/plugin_base.hpp:17:8: error: 'string' in namespace 'std' does not name a type
+ 17 | std::string log_tag, name;
+ | ^~~~~~
+../include/plugin_base.hpp:7:1: note: 'std::string' is defined in header '<string>'; did you forget to '#include <string>'?
+```
+---
+ include/plugin_base.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/plugin_base.hpp b/include/plugin_base.hpp
+index a2356fbf..79fd5452 100644
+--- a/include/plugin_base.hpp
++++ b/include/plugin_base.hpp
+@@ -4,6 +4,7 @@
+ #include <gio/gio.h>
+ #include <gst/gst.h>
+ #include <sigc++/sigc++.h>
++#include <string>
+
+ class PluginBase {
+ public:
diff --git a/media-sound/pulseeffects/metadata.xml b/media-sound/pulseeffects/metadata.xml
index e771c2411142..c0da3601cd32 100644
--- a/media-sound/pulseeffects/metadata.xml
+++ b/media-sound/pulseeffects/metadata.xml
@@ -5,11 +5,6 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
- <maintainer type="person">
- <email>jpizarrocallejas@gmail.com</email>
- <name>Jorge Pizarro Callejas</name>
- <description>Jorgicio Gentoo Overlay</description>
- </maintainer>
<use>
<flag name="bs2b">Enable use of media-libs/libbs2b</flag>
<flag name="calf">Enable use of media-plugins/calf for adding various FX</flag>
diff --git a/media-sound/pulseeffects/pulseeffects-4.7.2.ebuild b/media-sound/pulseeffects/pulseeffects-4.7.2-r1.ebuild
index 112dd9a47361..b12d12b7438a 100644
--- a/media-sound/pulseeffects/pulseeffects-4.7.2.ebuild
+++ b/media-sound/pulseeffects/pulseeffects-4.7.2-r1.ebuild
@@ -59,6 +59,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}/patch-4.7.2-gcc10.patch"
+)
+
pkg_postinst() {
gnome2_gconf_install
gnome2_schemas_update