summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/files/pip-7.1.2-unbundle.patch34
-rw-r--r--dev-python/pip/pip-7.1.2.ebuild66
3 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index e49ecf36d854..271de023f3ca 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -5,3 +5,4 @@ DIST pip-7.0.0.tar.gz 1053302 SHA256 7b46bfc1b95494731de306a688e2a7bc056d7fa7ad2
DIST pip-7.0.1.tar.gz 1053513 SHA256 cfec177552fdd0b2d12b72651c8e874f955b4c62c1c2c9f2588cbdc1c0d0d416 SHA512 cade5fbcd45e888330a1f78409bba406e009efe819701fed8c4e4abecd0ee1c5099c59290636f961d3b7e8266e1952fa586a5a290aeef13d90359585a7ea6600 WHIRLPOOL c77192dcd25cd7c9433e6281a8b424aa1745feae9cbbd3fe1a251ae3bedbd95ee623b8b82e210bcc4555e310ff3317331b94ce566c9f9decba990d898eb456ce
DIST pip-7.0.3.tar.gz 1054215 SHA256 b4c598825a6f6dc2cac65968feb28e6be6c1f7f1408493c60a07eaa731a0affd SHA512 b35efe45b4aff1a061f41561de7333415c081d9cbd2ee2eccf7af882ddaec643ec766d0f789b49bd94c961c60c6c2e420b31554f112b427bb3af690f4d00e731 WHIRLPOOL 23c45a70a87c61a3c01525abd46f877ec164e70c28e10aa3099590bf0c8421548828cb08f660016a1bdc73e535c18ebc85b734307b9a2f2e7c230518c574839e
DIST pip-7.1.0.tar.gz 1049267 SHA256 d5275ba3221182a5dd1b6bcfbfc5ec277fb399dd23226d6fa018048f7e0f10f2 SHA512 abda274dfe5f81e121bef9b3bf7a64218f72786037c17b0d99f36c954b09d6b5200a8b78f43de4739c813628a49cbb9d300e869766958e4ed177cf9caad8d511 WHIRLPOOL 35b2953c00a2ff4838f5f550016292b125f06d10f90736b96efc2240dadeebbba8be3d1b860efbe9989bffd51f5a6c5fa43234615b513cdc1aa900df8eb25f2a
+DIST pip-7.1.2.tar.gz 1049170 SHA256 ca047986f0528cfa975a14fb9f7f106271d4e0c3fe1ddced6c1db2e7ae57a477 SHA512 78082afe6b559bf87f91ae9b6d304cfbfce00206e09be42fdae9d449a55cd8d968df6873e834191d0b0e6baae29e72eb3eee42386ff7c5dc9c29b6c28b754449 WHIRLPOOL 953fdc9104f3ac34c9104ec93948f58c4b0e193f18da60d3247d801c283c574490f8b91146e4278888c0b920090f537095c1a1693ca352d062dd98473390fdc9
diff --git a/dev-python/pip/files/pip-7.1.2-unbundle.patch b/dev-python/pip/files/pip-7.1.2-unbundle.patch
new file mode 100644
index 000000000000..70adc20ead53
--- /dev/null
+++ b/dev-python/pip/files/pip-7.1.2-unbundle.patch
@@ -0,0 +1,34 @@
+ pip/_vendor/__init__.py | 13 +++++--------
+ 1 file changed, 5 insertions(+), 8 deletions(-)
+
+diff --git a/pip/_vendor/__init__.py b/pip/_vendor/__init__.py
+index ef8851d..349d022 100644
+--- a/pip/_vendor/__init__.py
++++ b/pip/_vendor/__init__.py
+@@ -14,7 +14,7 @@ import sys
+ # Downstream redistributors which have debundled our dependencies should also
+ # patch this value to be true. This will trigger the additional patching
+ # to cause things like "six" to be available as pip.
+-DEBUNDLED = False
++DEBUNDLED = True
+
+ # By default, look in this directory for a bunch of .whl files which we will
+ # add to the beginning of sys.path before attempting to import anything. This
+@@ -29,13 +29,10 @@ WHEEL_DIR = os.path.abspath(os.path.dirname(__file__))
+ def vendored(modulename):
+ vendored_name = "{0}.{1}".format(__name__, modulename)
+
+- try:
+- __import__(vendored_name, globals(), locals(), level=0)
+- except ImportError:
+- __import__(modulename, globals(), locals(), level=0)
+- sys.modules[vendored_name] = sys.modules[modulename]
+- base, head = vendored_name.rsplit(".", 1)
+- setattr(sys.modules[base], head, sys.modules[modulename])
++ __import__(modulename, globals(), locals(), level=0)
++ sys.modules[vendored_name] = sys.modules[modulename]
++ base, head = vendored_name.rsplit(".", 1)
++ setattr(sys.modules[base], head, sys.modules[modulename])
+
+
+ # If we're operating in a debundled setup, then we want to go ahead and trigger
diff --git a/dev-python/pip/pip-7.1.2.ebuild b/dev-python/pip/pip-7.1.2.ebuild
new file mode 100644
index 000000000000..8ddb91315665
--- /dev/null
+++ b/dev-python/pip/pip-7.1.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="https://pip.pypa.io/ https://pypi.python.org/pypi/pip/ https://github.com/pypa/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+# Check pip/_vendor/vendor.txt for this
+VENDOR_DEPEND="
+ >=dev-python/distlib-0.2.1
+ >=dev-python/html5lib-0.999999
+ >=dev-python/six-1.9
+ >=dev-python/colorama-0.3.3
+ >=dev-python/requests-2.7.0
+ >=dev-python/CacheControl-0.11.5
+ >=dev-python/lockfile-0.10.2
+ >=dev-python/progress-1.2
+ >=dev-python/ipaddress-1.0.14
+ >=dev-python/packaging-15.3
+ >=dev-python/retrying-1.3.3
+"
+RDEPEND="${VENDOR_DEPEND}
+ >=dev-python/setuptools-18.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch
+ "${FILESDIR}"/${P}-unbundle.patch
+ )
+
+python_prepare_all() {
+ mv pip/_vendor/__init__.py "${T}" || die
+ rm -r pip/_vendor/* || die
+ mv "${T}"/__init__.py pip/_vendor/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}