summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index cc7d19c5a950..a2648c6ac71c 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.0.tar.gz 662677 BLAKE2B caefb52696917646a773b378183261e14b7559b52ccfe99641f4ceb536bd908cda3888eed8ea447436073d53d9a5bd3a50bd05aaaa0b71ca52d94c3d7faa03d4 SHA512 95c3efd3b5cf2aab1c7bd47d72df43b2dc26757efc9d1452b8d654b50398073f414dfa70dfb2333c96c4c79649e868cff518040fccfb95cf6b44dfea73022d75
+DIST mod_h2-2.0.1.tar.gz 664404 BLAKE2B 94ee488f205e4ca0fdeb40e743b5679208698af97a33f965b2828e2b4f66bed4bb4ca99a23113039ed4766c73aa0aaf00377d379cfd52a5f605c197269702303 SHA512 2e2d6fb01abe34549a6ea81f33356ebbc667223d5ccb23f3027685deb9a4482cacf26be8d5cd30738afbf52be4f777f896bb8c0061bbfbbfc4ea5f2ace267468
diff --git a/www-apache/mod_h2/mod_h2-2.0.1.ebuild b/www-apache/mod_h2/mod_h2-2.0.1.ebuild
new file mode 100644
index 000000000000..352e2e78dea4
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}