summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest2
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0_p2.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
index 3574db5ee8fd..2bc23b1ba62a 100644
--- a/x11-themes/adwaita-icon-theme/Manifest
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -1,4 +1,6 @@
DIST adwaita-icon-theme-3.32.0.tar.xz 18540012 BLAKE2B a82ca6758cdbf459ac617d3b3d834e4147c3a3c5e6ca7c705ed2d16e8cf0a1255f5ae999d7e930b9716585b8c498c220f1ab40fec929dde7679efd56f3b18a45 SHA512 9609732cd51c6794d4d86598818bb2a589b0f4b6b795e57f3507dad69b21ef1b2fc2e83e24e937428bbace32fcccf587a5771cbc02c5768206e704f0456a6d1d
DIST adwaita-icon-theme-41.0.tar.xz 17086916 BLAKE2B 6899bf734a3f708e6596a4aeb2df426041dd46232a3cbd55f530fab2cc92277db74322a31a443e251a06c74bf7fad7d5f9394b63edb33fced5ce8987e5c87d3e SHA512 2a540f2b53cb64433780029ea70c2cfe8417ae7e619d8eefa59825e3ebcb8585acd4ccae25344c8e146a0ee0705ccbb39a2cb729a162534fd86a4ff24e505c86
DIST adwaita-icon-theme-42.0.tar.xz 10407000 BLAKE2B 1ec998731b8da4ed17d7bb5887faba7a33721955836265c67efeffcf16bbb82e6f20750245b9b6d7dc4e816ec0e6ae71cb51a839debb0e070edf5d347d6260d5 SHA512 521bfd44fdc253f5fd01fcdfaa485669849ad73c35354ccfe9b358ba433cfa40ee6d68b70ec2268a4ce0631a48670b03b30811ca68e2e19f9430082454e02015
+DIST adwaita-icon-theme_42.0-2.debian.tar.xz 38420 BLAKE2B 49d88218881bd064394faa320a90e0ce1ef3a1295fbb1fbb276fb79f99f1caf7a6b1b1600ad6c648a6cb479e7bc429101cd0c327bcb8da64d50c7ea1e7a1c8fe SHA512 0bcbad6e63a05b3e916b76e6e6e5b629cf859d7bfa8e0edb53112967921cc00b9217270b663aadd36bde4bea38769345ea54593337cc0c524cf998266a4a3f65
+DIST adwaita-icon-theme_42.0.orig-41.tar.xz 17086916 BLAKE2B 6899bf734a3f708e6596a4aeb2df426041dd46232a3cbd55f530fab2cc92277db74322a31a443e251a06c74bf7fad7d5f9394b63edb33fced5ce8987e5c87d3e SHA512 2a540f2b53cb64433780029ea70c2cfe8417ae7e619d8eefa59825e3ebcb8585acd4ccae25344c8e146a0ee0705ccbb39a2cb729a162534fd86a4ff24e505c86
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0_p2.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0_p2.ebuild
new file mode 100644
index 000000000000..8f5929ec582b
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-42.0_p2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
+
+# Rely on Debian workaround until all involved upstreams agree on how to
+# fix this: https://gitlab.gnome.org/GNOME/evolution/-/issues/1848
+SRC_URI="${SRC_URI/_p*}.tar.xz
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig-41.tar.xz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.48:2
+"
+BDEPEND="${PYTHON_DEPS}
+ >=gnome-base/librsvg-2.48:2
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-libs/gtk+:3
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/${P/_p*}"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+ einfo "Configuring legacy icons"
+ cd "${WORKDIR}/${PN}-41.0" && gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_compile() {
+ gnome2_src_compile
+ einfo "Compiling legacy icons"
+ cd "${WORKDIR}/${PN}-41.0" && gnome2_src_compile
+}
+
+pkg_preinst() {
+ # Needed until bug #834600 is solved
+ rm -r "${EROOT}"/usr/share/cursors/xorg-x11/Adwaita || die
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Gentoo uses the following location for cursors too, but keep
+ # upstream path to prevent issues like bugs #838451, #834277, #834001
+ dosym ../../../../usr/share/icons/Adwaita/cursors /usr/share/cursors/xorg-x11/Adwaita
+
+ # Fix until https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/commit/706d29cc5ca35bef6d0b3e682ae1752f33bf2705
+ # is in a release
+ dosym ../../../../../../usr/share/icons/Adwaita/scalable/actions/media-seek-backward-symbolic.svg /usr/share/icons/Adwaita/scalable/actions/media-seek-forward-symbolic-rtl.svg
+ dosym ../../../../../../usr/share/icons/Adwaita/scalable/actions/media-seek-forward-symbolic.svg /usr/share/icons/Adwaita/scalable/actions/media-seek-backward-symbolic-rtl.svg
+ dosym ../../../../../../usr/share/icons/Adwaita/scalable/actions/media-skip-backward-symbolic.svg /usr/share/icons/Adwaita/scalable/actions/media-skip-forward-symbolic-rtl.svg
+ dosym ../../../../../../usr/share/icons/Adwaita/scalable/actions/media-skip-forward-symbolic.svg /usr/share/icons/Adwaita/scalable/actions/media-skip-backward-symbolic-rtl.svg
+
+ # Install missing icons, bug #844910
+ # https://gitlab.gnome.org/GNOME/evolution/-/issues/1848
+ einfo "Installing legacy icons"
+ cd "${WORKDIR}/${PN}-41.0"
+ emake DESTDIR="${WORKDIR}/debian/tmp-41" install
+ "${PYTHON}" "${WORKDIR}/debian/move-subset.py" \
+ --icon-names-from-file="${WORKDIR}"/debian/legacy-icons-41.txt \
+ --icon-names-from-file="${WORKDIR}"/debian/removed-icons-41.txt \
+ "${WORKDIR}"/debian/tmp-41 \
+ "${ED}" || die
+}