summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2023.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 1cdd8c54e65e..4653706a1627 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,2 +1,3 @@
DIST xarray-2022.12.0.tar.gz 3060755 BLAKE2B 449d21234436983b478a022cf5585236738014c6f783039442c3d51870b62a62c61eaada6eb9df5305ada3fd5cdc87bf0201ffae1c835ec7a731c06badb718a7 SHA512 9c5c692392b15711d57254006ebc92cdda08b92b663a577701f50c52253d736d78e2ad027777ad588ffa23d523394576f0cf226986b05b22816d3cec1ea8abb7
DIST xarray-2023.2.0.tar.gz 3070514 BLAKE2B 00b08bb75878eed1aa82ac18ae5bc468d87812c90991f95b238048d53535dd884a943a068aec4114ba83c8e3cf1a37570b86ce5557fb33dc43f088a51916b92d SHA512 46b1e29e98a7c1bbe3275bc2fd39b0e5561319b4b9c6bf468c434880c9013c1dd9560b7281bd1b148ba8557cafe91ddf0ac56e5c038f1e995067ff1774162ab2
+DIST xarray-2023.3.0.tar.gz 3686167 BLAKE2B b9c2e04d0278e383aef17280e74863244d458324c01ac59a453e72196d65cad8fbca9f8f99a33b6db66637f742e04e5615fa8fc6eed307f0511954a856f8f3d2 SHA512 c08269e6fc8cdd3123dd7c39e0b85959bafdc53a5da75187fc615281fb71212bf2e45059f8d18fa05339567a4827e7bb68de3e605416929a6a1defdb4ed393e3
diff --git a/dev-python/xarray/xarray-2023.3.0.ebuild b/dev-python/xarray/xarray-2023.3.0.ebuild
new file mode 100644
index 000000000000..cc0d2354ba87
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ <dev-python/pandas-2[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)