summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-firewall/nftables/metadata.xml2
-rw-r--r--net-firewall/nftables/nftables-0.9.1.ebuild9
2 files changed, 9 insertions, 2 deletions
diff --git a/net-firewall/nftables/metadata.xml b/net-firewall/nftables/metadata.xml
index dcc71d66d6f8..0984d13e0f03 100644
--- a/net-firewall/nftables/metadata.xml
+++ b/net-firewall/nftables/metadata.xml
@@ -14,7 +14,9 @@
<name>Francisco Blas Izquierdo Riera</name>
</maintainer>
<use>
+ <flag name="doc">Create man pages for the package (requires <pkg>app-text/asciidoc</pkg>)</flag>
<flag name="json">Enable JSON support via <pkg>dev-libs/jansson</pkg></flag>
<flag name="modern_kernel">Install init scripts for 3.18 or higher kernels with atomic rule updates</flag>
+ <flag name="xtables">Add libxtables support to try to automatically translate rules added by iptables-compat</flag>
</use>
</pkgmetadata>
diff --git a/net-firewall/nftables/nftables-0.9.1.ebuild b/net-firewall/nftables/nftables-0.9.1.ebuild
index addd91fa7a8b..db6f707d58c6 100644
--- a/net-firewall/nftables/nftables-0.9.1.ebuild
+++ b/net-firewall/nftables/nftables-0.9.1.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://netfilter.org/projects/nftables/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
-IUSE="debug +gmp json +modern_kernel python +readline static-libs"
+IUSE="debug +doc +gmp json +modern_kernel python +readline static-libs xtables"
RDEPEND="
>=net-libs/libmnl-1.0.3:0=
@@ -23,11 +23,14 @@ RDEPEND="
json? ( dev-libs/jansson )
python? ( ${PYTHON_DEPS} )
readline? ( sys-libs/readline:0= )
- >=net-libs/libnftnl-1.1.3:0="
+ >=net-libs/libnftnl-1.1.3:0=
+ xtables? ( >=net-firewall/iptables-1.6.1 )
+"
DEPEND="${RDEPEND}"
BDEPEND="
+ doc? ( app-text/asciidoc )
>=app-text/docbook2X-0.8.8-r4
sys-devel/bison
sys-devel/flex
@@ -82,10 +85,12 @@ src_configure() {
--disable-python
--sbindir="${EPREFIX}"/sbin
$(use_enable debug)
+ $(use_enable doc man-doc)
$(use_with !gmp mini_gmp)
$(use_with json)
$(use_with readline cli)
$(use_enable static-libs static)
+ $(use_with xtables)
)
econf "${myeconfargs[@]}"
}