summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index b79eeacb3f46..fd23a3492dd5 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -157,10 +157,16 @@ src_prepare() {
sed -i -e 's/GROUP="dialout"/GROUP="uucp"/' rules/*.rules || die
local PATCHES=(
- "${FILESDIR}/218-Dont-enable-audit-by-default.patch"
- "${FILESDIR}/228-noclean-tmp.patch"
- "${FILESDIR}/232-systemd-user-pam.patch"
)
+
+ if ! use vanilla; then
+ PATCHES+=(
+ "${FILESDIR}/218-Dont-enable-audit-by-default.patch"
+ "${FILESDIR}/228-noclean-tmp.patch"
+ "${FILESDIR}/232-systemd-user-pam.patch"
+ )
+ fi
+
[[ -d "${WORKDIR}"/patches ]] && PATCHES+=( "${WORKDIR}"/patches )
default