summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/tinyproxy/Manifest1
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index dade097120ca..f53d028c839d 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -1,2 +1 @@
-DIST tinyproxy-1.11.0-rc1.tar.xz 176732 BLAKE2B a448c90b17a8d3256aec1dba4307e9bce87ac421a67486e4987afbf22e49041971138f09e98a4a775cc05071b73b4f1b34e652eb2c0992b2a5fa1861a0df26b2 SHA512 e1d05777072d178c66d1f007163bcb4b3a0b1dfdf460881daaf962b5f1c0d0213ec5403bf50c161d811f46c8b50a476cd534f535962ec01b70fbb955471c1af1
DIST tinyproxy-1.11.0.tar.xz 177664 BLAKE2B 6ea74ef0fff22fbc6e04b37519151fda771a7d3e789d94cbd2a77a76dce7b16151cfbad83ac665a5c1fdb7334cd4d26ed6d2bc73f70b3858ffe439b16698fd2e SHA512 c0ff2a90da2352e6021efc87d1293b85f2a7588b2a1ab13bd96d906382eda8188b22b01f9acb2d200fd570bf3ec9484fa370cae6834d1f055c0af1631d22ae9d
diff --git a/net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild b/net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild
deleted file mode 100644
index 29cef2869832..000000000000
--- a/net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd tmpfiles
-
-MY_PV=${PV/_/-}
-
-DESCRIPTION="A lightweight HTTP/SSL proxy"
-HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
-SRC_URI="https://github.com/tinyproxy/tinyproxy/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~sparc x86"
-
-IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
-+upstream-proxy +xtinyproxy-header"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( xtinyproxy-header )"
-
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-DEPEND="
- acct-group/tinyproxy
- acct-user/tinyproxy
-"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- sed -i \
- -e "s|nobody|${PN}|g" \
- etc/${PN}.conf.in || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable filter-proxy filter) \
- $(use_enable reverse-proxy reverse) \
- $(use_enable transparent-proxy transparent) \
- $(use_enable upstream-proxy upstream) \
- $(use_enable xtinyproxy-header xtinyproxy) \
- --localstatedir=/var
-}
-
-src_test() {
- # The make check target does not run the test suite
- emake test
-}
-
-src_install() {
- default
-
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- diropts -m0775 -o ${PN} -g ${PN}
- keepdir /var/log/${PN}
-
- newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
- systemd_newunit "${FILESDIR}"/${PN}-1.10.0.service tinyproxy.service
- dotmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.tmpfiles.conf
-
- elog "For filtering domains and URLs, enable filter option in the configuration"
- elog "file and add them to the filter file (one domain or URL per line)."
-}