summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xfe/Manifest1
-rw-r--r--x11-misc/xfe/xfe-1.42.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
index dfeab6554ce6..a1f33fb9e1a9 100644
--- a/x11-misc/xfe/Manifest
+++ b/x11-misc/xfe/Manifest
@@ -1,2 +1,3 @@
DIST xfe-1.40.1.tar.gz 2627754 SHA256 ec3d9495bb329c6199f6265dbfb514ffd3bdb8801e36ccc4e8fac6cea15bcc71 SHA512 d4d701dc84b342ca6f728073ff746d7308cc1cf1254956e41831cfa933649c7ac2ed32a55e6dc92047636e99f14d2609f5307aab5af07c700e597dd1cf4bf4cb WHIRLPOOL 00469cfe07604986b0a24fbcbb79c2174af6fc91ccaa7c08a47c31e6450ae637d3e1db002485d730f4ee241156c155754dcebd5a0d629941f101921c2825f533
DIST xfe-1.41.tar.gz 2752508 SHA256 d31ac9fdfa9223e54920ee8aabe20b43fa08ee4b6a5ee11a2d3c210506a3603f SHA512 eb9e1dfb02e5ae4bb9ccbf78bef8744ef61a72fb47795bb4598905c2f7ed01c65ed4443fd1b8981feb457b24daae1aa438170942eb97ec8b450c61b0742e4d2a WHIRLPOOL 9fc16836f8fb70d32b57902b504ccd438166d888da50049812f93b597e6dfa9920e357490d53f3718e4ae2b25d71977a528aeefa84d56d76d50ac7b5c85ce359
+DIST xfe-1.42.tar.gz 2727833 SHA256 a1e3e892584988c80b3a492f7b3cb78e1ee84d7148e6d1fc9d6054bbd8063bec SHA512 858dd761e45ff09d32d2a230304be0817eab4b6a772376b08d778bb8e1eef681228e5d88e53c441f9b8722d8b7eeae96980e30f8c5e8bb603d4d9a3b3d267351 WHIRLPOOL 388d95e5623a49a6a9eae22a5ee2a97d496445fb6bf395c4129d5be82f786cefea5c6c771423facd139241bf04777ea8b1ee839be503e171f3493b0751d517bd
diff --git a/x11-misc/xfe/xfe-1.42.ebuild b/x11-misc/xfe/xfe-1.42.ebuild
new file mode 100644
index 000000000000..aa618eda304e
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.42.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PLOCALES="
+ bs ca cs da de el es_AR es_CO es fr hu it ja nl no pl pt_BR pt_PT ru sv tr
+ zh_CN zh_TW
+"
+inherit autotools eutils l10n
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[png,truetype]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+
+ sed -i \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ --enable-minimalflags
+}