summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/fbpanel/fbpanel-7.0-r2.ebuild5
-rw-r--r--x11-misc/fbpanel/files/fbpanel-7.0-python3.10.patch9
2 files changed, 12 insertions, 2 deletions
diff --git a/x11-misc/fbpanel/fbpanel-7.0-r2.ebuild b/x11-misc/fbpanel/fbpanel-7.0-r2.ebuild
index bec7e0e0220b..94e70477e409 100644
--- a/x11-misc/fbpanel/fbpanel-7.0-r2.ebuild
+++ b/x11-misc/fbpanel/fbpanel-7.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1 toolchain-funcs
@@ -39,6 +39,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.0-images.patch
"${FILESDIR}"/${PN}-7.0-python3-shebangs.patch
"${FILESDIR}"/${PN}-7.0-remove-gdk-pixbuf-xlib.h.patch
+ "${FILESDIR}"/${PN}-7.0-python3.10.patch
)
src_prepare() {
diff --git a/x11-misc/fbpanel/files/fbpanel-7.0-python3.10.patch b/x11-misc/fbpanel/files/fbpanel-7.0-python3.10.patch
new file mode 100644
index 000000000000..1c7a5c0ac38e
--- /dev/null
+++ b/x11-misc/fbpanel/files/fbpanel-7.0-python3.10.patch
@@ -0,0 +1,9 @@
+python3.10 does not allow concatenating a string with None and
+this shouldn't be ran either way if None.
+--- a/configure
++++ b/configure
+@@ -75,3 +75,3 @@
+ self).add_argument_group(title, description)
+- if name != 'help' and len(name.split()) == 1:
++ if name != 'help' and len(name.split()) == 1 and title is not None:
+ self.add_argument("--help-" + name, group = 'help',