summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cryptography-vectors/Manifest1
-rw-r--r--dev-python/cryptography-vectors/cryptography-vectors-2.3.ebuild25
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-2.3.ebuild67
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/cryptography-vectors/Manifest b/dev-python/cryptography-vectors/Manifest
index 3d90c045a470..a77d313827d6 100644
--- a/dev-python/cryptography-vectors/Manifest
+++ b/dev-python/cryptography-vectors/Manifest
@@ -2,3 +2,4 @@ DIST cryptography_vectors-1.7.1.tar.gz 26652514 BLAKE2B 5aa670b4d52b010964465091
DIST cryptography_vectors-2.0.2.tar.gz 27011827 BLAKE2B eda02ca72a4a6a608050c531fc649a9843a9b7083a0a7a726ac89201f37016e258538671b15d4197deaffdb6902c345ff40e1da604e2b6034148d9c204b0ab1d SHA512 ab14bdf664e6df08c8436eb24c4465d3080aacd4e6cb47a0113b0877f869cd91d4184ad9122a428b323e91316b686eeb167c4e932773cac1e7b2adbc9309ca36
DIST cryptography_vectors-2.1.4.tar.gz 27255711 BLAKE2B 6c842b6366d794e9986110479e2175996b344aa191345c85a5cec8c0640b7a67b157f310eca31ac8e6487739357b11a2b86b9832fc680318e754c4751414c754 SHA512 74c2c1e3924f848488a3b5abdabda1a0089ae7d070b94e65f9fa2bf2da057ad27a37e46f90de4f2c3e9f1cc96c1c179cb5dbf0f50d5166a02846923e3bceb165
DIST cryptography_vectors-2.2.2.tar.gz 27270814 BLAKE2B b57cfd402e85e34a1e52d034ef51699ba9ab7381e5baa28f0f062ecc8d6b7b5849ac4d5426c41768e1a4fb9462f84d7e22476ec64dc0bd0142a799caaf95eafb SHA512 bdaf53c8087d6c44fcd3ab54069d1d45b60ee80d98fd813fe180b9e88272203b5dd2abd5fa6dcd3b4ce9ec3215997fd8e99e63309e2f0ac619a6f72d552afff9
+DIST cryptography_vectors-2.3.tar.gz 35303908 BLAKE2B 694f5a741ddedce2101632dcf165961d4706feaa5c8482235f5afb69f4257bfb4f8a9b8423213661de0da2d56ebf43cc7ba138a4bbf9462f367ebd5adf2620f7 SHA512 7c51b0c29c182c4da3265824a1b6e44c943bd41dfa89199cded963d0182a8ade678a560ec9ea13f6e8918119fcacf1c90d804cc90368e51cc5d430228448231c
diff --git a/dev-python/cryptography-vectors/cryptography-vectors-2.3.ebuild b/dev-python/cryptography-vectors/cryptography-vectors-2.3.ebuild
new file mode 100644
index 000000000000..6c1b08319c74
--- /dev/null
+++ b/dev-python/cryptography-vectors/cryptography-vectors-2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Test vectors for the cryptography package"
+HOMEPAGE="https://pypi.org/project/cryptography-vectors/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index 032127fab865..179000c042e6 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -2,3 +2,4 @@ DIST cryptography-1.7.1.tar.gz 420673 BLAKE2B 8c0257187f29173bae610f191f6ae3251e
DIST cryptography-2.0.2.tar.gz 427303 BLAKE2B 53f891c02aa4b82b13a66a4c74bd6db9e8dcdb57bd0bba76648e0c1be710ce1d94c8425ead6d81b240b39c034125ce320757d4b43c56bc7410af11f171cf9a21 SHA512 a71219ff52006a7c8bf1553d0f132c747566c630281ef89aac40c65b193b1f0074fc9cda1de7057c76b452113dfb6188c83baef3ed9c05ff18adbc8b7bba646b
DIST cryptography-2.1.4.tar.gz 441557 BLAKE2B 66aa07930ee54469328977e27096e65b7a333b38b71828c71cb7891b489ef7af60f5e5590f67b43d5e63dc2279d9ca1ba036879f3145264f7639d65000958b50 SHA512 f749cb4384badc174a842514e5a4fee2ed01ab9c716799d8d9d5301f6d2d97b6c41deb9e425f48928b639fa34bef8c05529ed7e5b777ef5ca75c244f8fda8fd4
DIST cryptography-2.2.2.tar.gz 443822 BLAKE2B d0fbaad78d172f1ba1bfa6edd64d2d5a0eac0853a564fdbb9830dfedc5c53fe1b28d8c1878be85ce38b8cd90a0c2e40e6a209158693a88a7053a80f0481e6302 SHA512 6c1b19cdb870d65abad42523697e9a0bebc7a0025b34f10c4bdd30c313333efd7c41bcb4237a29b3a1b270e3fbade75ccb35df172b055b7c075d619f4d9424c9
+DIST cryptography-2.3.tar.gz 449464 BLAKE2B 7485c745f9c6512a5efce42181970deff19bd4420e91230d84b070cd77450a6805c56a2e37cda73b45c90ed969c8fdbb866a7cc9e53a6828a1ca6e45befd9de8 SHA512 75e14020da500fdbbd578f004b22ef3237844185329adf59288b29f1b3ee9dd2005a2c4a933fe8609a59d168012a9f687bab0f31ab39ed6ca325198aa9295e52
diff --git a/dev-python/cryptography/cryptography-2.3.ebuild b/dev-python/cryptography/cryptography-2.3.ebuild
new file mode 100644
index 000000000000..b86ee83bd1e6
--- /dev/null
+++ b/dev-python/cryptography/cryptography-2.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.org/project/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="libressl test"
+
+# the openssl 1.0.2l-r1 needs to be updated again :(
+# It'd theb be able to go into the || section again
+#=dev-libs/openssl-1.0.2l-r1:0
+# the following is the original section, disallowing bindist entirely
+#!libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist(-)] )
+RDEPEND="
+ !libressl? (
+ dev-libs/openssl:0= (
+ || (
+ dev-libs/openssl:0[-bindist(-)]
+ >=dev-libs/openssl-1.0.2o-r2:0
+ )
+ )
+ )
+ libressl? ( dev-libs/libressl:0= )
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '!~dev-python/cffi-1.11.3:=[${PYTHON_USEDEP}]' 'python*')
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+PATCHES=(
+)
+
+python_configure_all() {
+ append-cflags $(test-flags-CC -pthread)
+}
+
+python_test() {
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}