summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/vdr-live/Manifest2
-rw-r--r--media-plugins/vdr-live/files/confd-0.223
-rw-r--r--media-plugins/vdr-live/files/rc-addon-0.2.sh25
-rw-r--r--media-plugins/vdr-live/files/vdr-live-0.3.0_p20130504_vdr-2.1.2.diff69
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild105
-rw-r--r--media-plugins/vdr-live/vdr-live-2.3.1.ebuild99
6 files changed, 0 insertions, 323 deletions
diff --git a/media-plugins/vdr-live/Manifest b/media-plugins/vdr-live/Manifest
index 3f7b768efc03..96e6185d9397 100644
--- a/media-plugins/vdr-live/Manifest
+++ b/media-plugins/vdr-live/Manifest
@@ -1,3 +1 @@
-DIST vdr-live-0.3.0_p20130504.tar.bz2 6348021 BLAKE2B 64567a037dd283d005727b993053609e7c46784de67bcbd9afb4f68edd03cec494e6eca6c497ac578928de92c1d21b2519867c014cfd11ace79e957fc5d487d1 SHA512 7a238a4567f90448b7813366dbdb5112ab98079fd5a2c9d59d09273853fd62ad520ca9ad373704a8888eb7c25119772421fe998d87069647c40d6d2d869e09c1
-DIST vdr-live-2.3.1.tar.bz2 703327 BLAKE2B 70724894a4abf2f94d682602d722b3d015cefefa7c9daf2dae35fc84bff1d950539c916d6d97e39565e87e8e7d841277ad14e137238026b25f73b1b288fa18f5 SHA512 f943c2aa477ca943b2015eb0b49a650e5c9e5cc124549b68d36b56a0ae6344a8d32ac3c4f213ab3cb91794ae569d3ed14a84168f45bf395e90536992078bce41
DIST vdr-live-3.0.6.tar.gz 737583 BLAKE2B e9fd7f95df7c3fcd11e9e63131c948c1d318e2bb0c5cbc2fab950abc2889df8ca8a33b71f5394b3c22c45f81ee1faf1bf71ca889ae64173be8965db6f6fbd8ac SHA512 f60cd14c3a02eeb571ffc181dabd83dd0af0595d378ed34bc9cee1d54b560d74027c758d3b4d69541a71dc6f94b5f64e3972fc51aeb5a9d688be7656636bcf98
diff --git a/media-plugins/vdr-live/files/confd-0.2 b/media-plugins/vdr-live/files/confd-0.2
deleted file mode 100644
index bbbbcb5e9d42..000000000000
--- a/media-plugins/vdr-live/files/confd-0.2
+++ /dev/null
@@ -1,23 +0,0 @@
-# configuration of media-plugins/vdr-live
-
-# for people who want more secure
-# with ssl access.
-# on usage, you have to install vdr-live
-# with USE="ssl"
-#
-# SSL ADDRESS --> https://<your-ip>:8443/
-#
-# allowed values: yes no
-# default: no
-#LIVE_USE_SSL="yes"
-
-# default given portnumber
-# only changes needed on problems
-#
-#LIVE_PORT="8008"
-#LIVE_SSL_PORT="8443"
-
-# bind to these IP addresses
-# default, your IP will automaticly detected
-#
-LIVE_BIND_IPS="127.0.0.1"
diff --git a/media-plugins/vdr-live/files/rc-addon-0.2.sh b/media-plugins/vdr-live/files/rc-addon-0.2.sh
deleted file mode 100644
index 54d37d795ea2..000000000000
--- a/media-plugins/vdr-live/files/rc-addon-0.2.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#
-# zzam@g.o
-# hd_brummy@g.o
-
-
-plugin_pre_vdr_start() {
- if [ "${LIVE_USE_SSL:=no}" = "yes" ]; then
- if [ -n "${LIVE_SSL_PORT}" ]; then
- add_plugin_param "-s ${LIVE_SSL_PORT}"
- fi
-
- add_plugin_param "--cert=/etc/vdr/plugins/live/live.pem"
- add_plugin_param "--key=/etc/vdr/plugins/live/live-key.pem"
-
- else
- if [ -n "${LIVE_PORT}" ]; then
- add_plugin_param "-p ${LIVE_PORT}"
- fi
- fi
-
- local ip
- for ip in ${LIVE_BIND_IPS:=`hostname -i`}; do
- add_plugin_param "-i ${ip}"
- done
-}
diff --git a/media-plugins/vdr-live/files/vdr-live-0.3.0_p20130504_vdr-2.1.2.diff b/media-plugins/vdr-live/files/vdr-live-0.3.0_p20130504_vdr-2.1.2.diff
deleted file mode 100644
index 1346c9be611d..000000000000
--- a/media-plugins/vdr-live/files/vdr-live-0.3.0_p20130504_vdr-2.1.2.diff
+++ /dev/null
@@ -1,69 +0,0 @@
-diff -Naur vdr-live-0.3.0_p20130504.orig/pages/recordings.ecpp vdr-live-0.3.0_p20130504/pages/recordings.ecpp
---- vdr-live-0.3.0_p20130504.orig/pages/recordings.ecpp 2013-10-23 03:28:13.746493449 +0200
-+++ vdr-live-0.3.0_p20130504/pages/recordings.ecpp 2013-10-23 03:29:48.779832793 +0200
-@@ -79,7 +79,11 @@
- deletions.clear();
-
- int FreeMB, UsedMB;
-+#if APIVERSNUM > 20101
-+int Percent = cVideoDirectory::VideoDiskSpace(&FreeMB, &UsedMB);
-+#else
- int Percent = VideoDiskSpace(&FreeMB, &UsedMB);
-+#endif
- int Minutes = int(double(FreeMB) / MB_PER_MINUTE);
- int Hours = Minutes / 60;
- Minutes %= 60;
-diff -Naur vdr-live-0.3.0_p20130504.orig/recman.cpp vdr-live-0.3.0_p20130504/recman.cpp
---- vdr-live-0.3.0_p20130504.orig/recman.cpp 2013-10-23 03:28:13.756493450 +0200
-+++ vdr-live-0.3.0_p20130504/recman.cpp 2013-10-23 03:31:25.813172263 +0200
-@@ -112,7 +112,11 @@
- if (found == string::npos)
- return false;
-
-+#if APIVERSNUM > 20101
-+ string newname = string(cVideoDirectory::Name()) + "/" + name + oldname.substr(found);
-+#else
- string newname = string(VideoDirectory) + "/" + name + oldname.substr(found);
-+#endif
-
- if (!MoveDirectory(oldname.c_str(), newname.c_str(), copy)) {
- esyslog("[LIVE]: renaming failed from '%s' to '%s'", oldname.c_str(), newname.c_str());
-diff -Naur vdr-live-0.3.0_p20130504.orig/tools.cpp vdr-live-0.3.0_p20130504/tools.cpp
---- vdr-live-0.3.0_p20130504.orig/tools.cpp 2013-10-23 03:28:13.799826786 +0200
-+++ vdr-live-0.3.0_p20130504/tools.cpp 2013-10-23 03:34:29.146517191 +0200
-@@ -365,7 +365,11 @@
- stat(source.c_str(), &st1);
- stat(target.c_str(),&st2);
- if (!copy && (st1.st_dev == st2.st_dev)) {
-+#if APIVERSNUM > 20101
-+ if (!cVideoDirectory::RenameVideoFile(source.c_str(), target.c_str())) {
-+#else
- if (!RenameVideoFile(source.c_str(), target.c_str())) {
-+#endif
- esyslog("[LIVE]: rename failed from %s to %s", source.c_str(), target.c_str());
- return false;
- }
-@@ -461,7 +465,11 @@
- size_t found = source.find_last_of(delim);
- if (found != std::string::npos) {
- source = source.substr(0, found);
-+#if APIVERSNUM > 20101
-+ while (source != cVideoDirectory::Name()) {
-+#else
- while (source != VideoDirectory) {
-+#endif
- found = source.find_last_of(delim);
- if (found == std::string::npos)
- break;
-@@ -478,7 +486,11 @@
- size_t found = target.find_last_of(delim);
- if (found != std::string::npos) {
- target = target.substr(0, found);
-+#if APIVERSNUM > 20101
-+ while (target != cVideoDirectory::Name()) {
-+#else
- while (target != VideoDirectory) {
-+#endif
- found = target.find_last_of(delim);
- if (found == std::string::npos)
- break;
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
deleted file mode 100644
index 3d0c535fa2fd..000000000000
--- a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic vdr-plugin-2 ssl-cert
-
-DESCRIPTION="VDR Plugin: Web Access To Settings"
-HOMEPAGE="http://live.vdr-developer.org"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
-
-LICENSE="GPL-2 RSA"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="pcre ssl"
-
-DEPEND="media-video/vdr
- >=dev-libs/tntnet-2.2.1[ssl=]
- >=dev-libs/cxxtools-2.2.1
- pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-0.2"
-VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.2.sh"
-
-KEEP_I18NOBJECT="yes"
-
-make_live_cert() {
- # TODO: still true?
- # ssl-cert eclass creates a "invalid" cert, create our own one
- local base=$(get_base 1)
- local keydir="/etc/vdr/plugins/live"
-
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
- SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
-
- echo
- gen_cnf || return 1
- echo
- gen_key 1 || return 1
- gen_csr 1 || return 1
- gen_crt 1 || return 1
- echo
-
- install -d "${ROOT}${keydir}"
- install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
- install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
- chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
-}
-
-src_configure() {
- # tmp. disabled gcc -std=c++11, due massiv compile errors
- filter-flags -std=c++11
-}
-
-src_prepare() {
- # remove untranslated language files
- rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
-
- vdr-plugin-2_src_prepare
-
- epatch "${FILESDIR}/${P}_vdr-2.1.2.diff"
-
- if ! use pcre; then
- sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
- fi
-}
-
-src_install() {
- vdr-plugin-2_src_install
-
- insinto /usr/share/vdr/plugins/live
- doins -r live/*
-
- fowners -R vdr:vdr /usr/share/vdr/plugins/live
-}
-
-pkg_postinst() {
- vdr-plugin-2_pkg_postinst
-
- elog "To be able to use all functions of vdr-live"
- elog "you should emerge and enable"
- elog "media-plugins/vdr-epgsearch to search the EPG,"
- elog "media-plugins/vdr-streamdev for Live-TV streaming"
-
- elog "The default username/password is:"
- elog "\tadmin:live"
-
- if use ssl ; then
- if [[ -f ${ROOT}/etc/vdr/plugins/live/live.pem ]]; then
- einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
- einfo "emerge --config ${PN}"
- else
- einfo "No SSL cert found, creating a default one now"
- make_live_cert
- fi
- fi
-}
-
-pkg_config() {
- make_live_cert
-}
diff --git a/media-plugins/vdr-live/vdr-live-2.3.1.ebuild b/media-plugins/vdr-live/vdr-live-2.3.1.ebuild
deleted file mode 100644
index 965fe62f8ffa..000000000000
--- a/media-plugins/vdr-live/vdr-live-2.3.1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vdr-plugin-2 ssl-cert
-
-MY_P="release_2-3-1"
-
-DESCRIPTION="VDR Plugin: Web Access To Settings"
-HOMEPAGE="http://live.vdr-developer.org"
-SRC_URI="https://projects.vdr-developer.org/git/vdr-plugin-live.git/snapshot/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="GPL-2 RSA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pcre ssl"
-
-DEPEND="media-video/vdr
- >=dev-libs/tntnet-2.2.1[ssl=]
- >=dev-libs/cxxtools-2.2.1
- pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-2.3"
-VDR_RCADDON_FILE="${FILESDIR}/rc-addon-2.3.sh"
-
-KEEP_I18NOBJECT="yes"
-
-make_live_cert() {
- # TODO: still true?
- # ssl-cert eclass creates a "invalid" cert, create our own one
- local base=$(get_base 1)
- local keydir="/etc/vdr/plugins/live"
-
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
- SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
-
- echo
- gen_cnf || return 1
- echo
- gen_key 1 || return 1
- gen_csr 1 || return 1
- gen_crt 1 || return 1
- echo
-
- install -d "${ROOT}${keydir}"
- install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
- install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
- chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
-}
-
-src_prepare() {
- # remove untranslated language files
- rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pt_PT,ro_RO,sl_SI,tr_TR}.po
-
- vdr-plugin-2_src_prepare
-
- if ! use pcre; then
- sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
- fi
-}
-
-src_install() {
- vdr-plugin-2_src_install
-
- insinto /usr/share/vdr/plugins/live
- doins -r live/*
-
- fowners -R vdr:vdr /usr/share/vdr/plugins/live
-}
-
-pkg_postinst() {
- vdr-plugin-2_pkg_postinst
-
- elog "To be able to use all functions of vdr-live"
- elog "you should emerge and enable"
- elog "media-plugins/vdr-epgsearch to search the EPG,"
- elog "media-plugins/vdr-streamdev for Live-TV streaming"
-
- elog "The default username/password is:"
- elog "\tadmin:live"
-
- if use ssl ; then
- if [[ -f ${ROOT}/etc/vdr/plugins/live/live.pem ]]; then
- einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
- einfo "emerge --config ${PN}"
- else
- einfo "No SSL cert found, creating a default one now"
- make_live_cert
- fi
- fi
-}
-
-pkg_config() {
- make_live_cert
-}