summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-32.0.0.192.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index 8b102c574167..e2d98f5e7117 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-32.0.0.171-npapi.i386.tar.gz 8530615 BLAKE2B dce661eabe8c665ac3
DIST adobe-flash-32.0.0.171-npapi.x86_64.tar.gz 9046293 BLAKE2B 5f35e1b0ee7a4c19ba8c3769159bf5e2b82c9de1bce1eb2097877a5bc63e8f9aab6a416a0439cf91889335f755457373ba9857a9e43b706404ff36a31123a76b SHA512 b6e8c0670a0f5189dc5e82e50c2be227f826068eedda8f025ac44b7d349baad033bb8f80b8018fac186c5d3b7dead679f6a27197f38e3ba1e047c9af190e2f75
DIST adobe-flash-32.0.0.171-ppapi.i386.tar.gz 8565037 BLAKE2B 7a79b76c2e55ee2f9d1d1b19519ea4416d6a5ab1735f4581ee6604890e83590170528e3a02f2803e71011acf14d996968033ba9ca3ae3124238ccaf9d8d15bc5 SHA512 d7d3e4114d27690b22140e57fc149264e247c87136bb04d84bc2a515468757220261cd70420f4a37c8f6614a6a675d8d8cea8c7f0cdba941846e0e4ed143e940
DIST adobe-flash-32.0.0.171-ppapi.x86_64.tar.gz 9482109 BLAKE2B ed593b981d4cf49821666d5d9cbe343377a7c5cb6a461bd21af543c6f68809fc740fd132fad561fe94f64a596660ba0bfc29c4c57e621e687ec2e91bf663540b SHA512 45327247ff018e55808e40049b8a593609a4ca94e8c8bade926415fda9d04b88abea07ae3aebe9e3e32fad6319c80a95a941fba43b4d1abc8df2cfa5f368660b
+DIST adobe-flash-32.0.0.192-npapi.i386.tar.gz 8536032 BLAKE2B 28c1d5616756934d16650425f472672b472425739c5f80c698b9c67403e13da102c79d3d0bdd82e5343a38ded06387dfaabf576bcb7a59525513f7cb26c4ea52 SHA512 92e0883540fdea58792c6075504d407bc07c44c5368ada74af28bfc7256406d18f284fb0e4051c143ef7fea3df179ea7fb84f1011858b6a9050f3980143a5877
+DIST adobe-flash-32.0.0.192-npapi.x86_64.tar.gz 9051565 BLAKE2B 074e06736e1c1766330ad54d685f3e1c1f60ededffc800939abcabb65fdbf12fb5cd7c364b764e001939773cd85ed18e6c2e3fa2c8923a9a4a1b2aad591944e3 SHA512 4db4ae53e92878d1fade66dfee1c29744f86a45cd37b2822be83bc8b0a6ab4684e8e158d8754e678265af763e64fa208be318cbf0588845b86529bc1eca8734a
+DIST adobe-flash-32.0.0.192-ppapi.i386.tar.gz 8569493 BLAKE2B 428d4f239157ae63614b0b5489d586da31e099bc64ed1a12f09d76a3bbba048872977b87ab608659d1122bd8da9d206bb737f7fe56b3569adf8281f556e0fdec SHA512 5c299783a549377d55818ecc5bfd89aeb789508d41d8abb13e415908da6a3efca021e91927c726311e6fdc1a340d6ef5e20d918149c7965d5feada95241f7d7a
+DIST adobe-flash-32.0.0.192-ppapi.x86_64.tar.gz 9489423 BLAKE2B 9e3ac444562ffca1075dd00e329d98a5c4f44a945beedcf92b78aca982d2d6b72160c68a6cc1c7697071ed602b553f3399520fb8f9c0540bb50ea630c324682b SHA512 0039f432a675fa036600c91a05a2db9828b8c350ec45dbcc1d110801231ddadeff478da182e887aa2b3d32dce2d208bdfd1f4aca01c2a08d37f2382049b114e0
diff --git a/www-plugins/adobe-flash/adobe-flash-32.0.0.192.ebuild b/www-plugins/adobe-flash/adobe-flash-32.0.0.192.ebuild
new file mode 100644
index 000000000000..2cc1c70b340d
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-32.0.0.192.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}