summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cppcheck/Manifest1
-rw-r--r--dev-util/cppcheck/cppcheck-1.84-r1.ebuild110
-rw-r--r--dev-util/cppcheck/cppcheck-1.84.ebuild107
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.84-char-signedness.patch88
4 files changed, 0 insertions, 306 deletions
diff --git a/dev-util/cppcheck/Manifest b/dev-util/cppcheck/Manifest
index 6bde7d45d7af..ea5ae23f7047 100644
--- a/dev-util/cppcheck/Manifest
+++ b/dev-util/cppcheck/Manifest
@@ -1,4 +1,3 @@
DIST cppcheck-1.81.tar.bz2 1514741 BLAKE2B 2f23dfe4bdb26e203411f0bf9bc569303a4d59f96911b32a8a5f9cc9a6a7fa75e5d87c328cb0bf8cc46bd8f38747a4663c33243b8385355cc5630e1fcf6c891f SHA512 22e7b63c35e71b2784065faca06aec8c286e3173f182ac10995073cc3d61fd0bfaf353c51ad9207d3bd2c6134ab1a3990a37668709505b657c2816d561f8af92
-DIST cppcheck-1.84.tar.gz 2051244 BLAKE2B 8e4b4c71da969addec6d1cb2919c39625054797ae730c85555695e872f87295c20e4564db2eadf536a762ca018882285d5d329f9a5789608e14ef17f1069753d SHA512 7f971f9097db6d2fee7483634afc697bddff499a7b09c4be0bfdc3f8e502d47202a8d4f4fc1a330d0fb1d34a7772065b96419b4b4f4f1467b997e62459304526
DIST cppcheck-1.85.tar.gz 2150637 BLAKE2B 73a1d4e1fb0770103c8163f35b9e710a5863561df66e46e319b9246ed14e3c5d4d73511db6e70275de4f4510866d7e1888b0fd6b49e5b01fc4f08d081119b36c SHA512 cc984c751d87150839782e96b3762dbf918d9e3687562eabaff6473e48e3254995dd3bffe8605842f867d7ad76845ca2248a53bbd54b5c367281db8a1c1c7fad
DIST cppcheck-1.86.tar.gz 2184186 BLAKE2B 8b488ec72d0998d6b037de2b1204373c8b3de475ad165bf108bb331399356cb0d1e20a7bc6f368f1a038ec886ad7a84ad694172d0a96a203a6877f3838c21001 SHA512 59cec55b8408e8f2e2e7172bce69350c248bc3185a0938b523c44a58f98b344e11aef957ec1b7a7b2bc7a876660b2683e51f54b76f0b550f9549497c29453655
diff --git a/dev-util/cppcheck/cppcheck-1.84-r1.ebuild b/dev-util/cppcheck/cppcheck-1.84-r1.ebuild
deleted file mode 100644
index 82a4ecbe4b9c..000000000000
--- a/dev-util/cppcheck/cppcheck-1.84-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 flag-o-matic qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="http://cppcheck.sourceforge.net"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
- dev-libs/tinyxml2:=
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.75-tinyxml2.patch
- "${FILESDIR}"/${PN}-1.84-char-signedness.patch
-)
-
-src_prepare() {
- default
- append-cxxflags -std=c++0x
-
- # Drop bundled libs, patch Makefile generator and re-run it
- rm -r externals/tinyxml || die
- tc-export CXX
- emake dmake
- ./dmake || die
-}
-
-src_configure() {
- if use pcre ; then
- sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile || die
- fi
-}
-
-src_compile() {
- export LIBS="$(pkg-config --libs tinyxml2)"
- emake ${PN} man \
- CFGDIR="${EROOT}usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
- if use qt5 ; then
- pushd gui || die
- eqmake5
- emake
- popd || die
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_test() {
- # safe final version
- mv -v ${PN}{,.final} || die
- mv -v lib/library.o{,.final} || die
- mv -v cli/cppcheckexecutor.o{,.final} || die
- #trigger recompile with CFGDIR inside ${S}
- emake check CFGDIR="${S}/cfg"
- # restore
- mv -v ${PN}{.final,} || die
- mv -v lib/library.o{.final,} || die
- mv -v cli/cppcheckexecutor.o{.final,} || die
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin gui/${PN}-gui
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
- doman ${PN}.1
- dodoc -r triage
-}
diff --git a/dev-util/cppcheck/cppcheck-1.84.ebuild b/dev-util/cppcheck/cppcheck-1.84.ebuild
deleted file mode 100644
index 2fb1dddad4b9..000000000000
--- a/dev-util/cppcheck/cppcheck-1.84.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 flag-o-matic qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="http://cppcheck.sourceforge.net"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
- dev-libs/tinyxml2:=
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.75-tinyxml2.patch )
-
-src_prepare() {
- default
- append-cxxflags -std=c++0x
-
- # Drop bundled libs, patch Makefile generator and re-run it
- rm -r externals/tinyxml || die
- tc-export CXX
- emake dmake
- ./dmake || die
-}
-
-src_configure() {
- if use pcre ; then
- sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile || die
- fi
-}
-
-src_compile() {
- export LIBS="$(pkg-config --libs tinyxml2)"
- emake ${PN} man \
- CFGDIR="${EROOT}usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
- if use qt5 ; then
- pushd gui || die
- eqmake5
- emake
- popd || die
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_test() {
- # safe final version
- mv -v ${PN}{,.final} || die
- mv -v lib/library.o{,.final} || die
- mv -v cli/cppcheckexecutor.o{,.final} || die
- #trigger recompile with CFGDIR inside ${S}
- emake check CFGDIR="${S}/cfg"
- # restore
- mv -v ${PN}{.final,} || die
- mv -v lib/library.o{.final,} || die
- mv -v cli/cppcheckexecutor.o{.final,} || die
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin gui/${PN}-gui
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
- doman ${PN}.1
- dodoc -r triage
-}
diff --git a/dev-util/cppcheck/files/cppcheck-1.84-char-signedness.patch b/dev-util/cppcheck/files/cppcheck-1.84-char-signedness.patch
deleted file mode 100644
index ee1b136c9a9a..000000000000
--- a/dev-util/cppcheck/files/cppcheck-1.84-char-signedness.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 320a957bbc912325363cf86b61108db860195ec3 Mon Sep 17 00:00:00 2001
-From: Alexander Mai <amai@users.sf.net>
-Date: Thu, 28 Jun 2018 22:16:18 +0200
-Subject: [PATCH] Extend TestSymbolDatabase::findFunction19 to outline
- different results depending whether char is signed or unsigned on compile
- time
-
----
- test/testsymboldatabase.cpp | 28 ++++++++++++++++++++--------
- 1 file changed, 20 insertions(+), 8 deletions(-)
-
-diff --git a/test/testsymboldatabase.cpp b/test/testsymboldatabase.cpp
-index 0dafd2730..28473e8e9 100644
---- a/test/testsymboldatabase.cpp
-+++ b/test/testsymboldatabase.cpp
-@@ -26,6 +26,7 @@
- #include "tokenlist.h"
- #include "utils.h"
-
-+#include <climits>
- #include <cstddef>
- #include <list>
- #include <map>
-@@ -5065,6 +5066,7 @@ private:
- " long get(long x) { return x; }\n"
- " long long get(long long x) { return x; }\n"
- " unsigned char get(unsigned char x) { return x; }\n"
-+ " signed char get(signed char x) { return x; }\n"
- " unsigned short get(unsigned short x) { return x; }\n"
- " unsigned int get(unsigned int x) { return x; }\n"
- " unsigned long get(unsigned long x) { return x; }\n"
-@@ -5079,12 +5081,13 @@ private:
- " long v5 = 1; v5 = get(get(v5));\n"
- " long long v6 = 1; v6 = get(get(v6));\n"
- " unsigned char v7 = '1'; v7 = get(get(v7));\n"
-- " unsigned short v8 = 1; v8 = get(get(v8));\n"
-- " unsigned int v9 = 1; v9 = get(get(v9));\n"
-- " unsigned long v10 = 1; v10 = get(get(v10));\n"
-- " unsigned long long v11 = 1; v11 = get(get(v11));\n"
-- " E1 v12 = e1; v12 = get(get(v12));\n"
-- " E2 v13 = E2::e2; v13 = get(get(v13));\n"
-+ " signed char v8 = '1'; v8 = get(get(v8));\n"
-+ " unsigned short v9 = 1; v9 = get(get(v9));\n"
-+ " unsigned int v10 = 1; v10 = get(get(v10));\n"
-+ " unsigned long v11 = 1; v11 = get(get(v11));\n"
-+ " unsigned long long v12 = 1; v12 = get(get(v12));\n"
-+ " E1 v13 = e1; v13 = get(get(v13));\n"
-+ " E2 v14 = E2::e2; v14 = get(get(v14));\n"
- " }\n"
- "};");
-
-@@ -5094,7 +5097,10 @@ private:
- ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 4);
-
- f = Token::findsimplematch(tokenizer.tokens(), "get ( get ( v2 ) ) ;");
-- ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 5);
-+ if (std::numeric_limits<char>::is_signed)
-+ ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 5);
-+ else
-+ ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 10);
-
- f = Token::findsimplematch(tokenizer.tokens(), "get ( get ( v3 ) ) ;");
- ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 6);
-@@ -5112,7 +5118,10 @@ private:
- ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 10);
-
- f = Token::findsimplematch(tokenizer.tokens(), "get ( get ( v8 ) ) ;");
-- ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 11);
-+ if (std::numeric_limits<char>::is_signed)
-+ ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 5);
-+ else
-+ ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 10);
-
- f = Token::findsimplematch(tokenizer.tokens(), "get ( get ( v9 ) ) ;");
- ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 12);
-@@ -5128,6 +5137,9 @@ private:
-
- f = Token::findsimplematch(tokenizer.tokens(), "get ( get ( v13 ) ) ;");
- ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 16);
-+
-+ f = Token::findsimplematch(tokenizer.tokens(), "get ( get ( v14 ) ) ;");
-+ ASSERT_EQUALS(true, db && f && f->function() && f->function()->tokenDef->linenr() == 17);
- }
-
- void findFunction20() { // # 8280
---
-2.16.4
-