summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-misc/systemd-kcm/files/systemd-kcm-1.2.1-qt-5.11b3.patch36
-rw-r--r--kde-misc/systemd-kcm/systemd-kcm-1.2.1.ebuild5
2 files changed, 39 insertions, 2 deletions
diff --git a/kde-misc/systemd-kcm/files/systemd-kcm-1.2.1-qt-5.11b3.patch b/kde-misc/systemd-kcm/files/systemd-kcm-1.2.1-qt-5.11b3.patch
new file mode 100644
index 000000000000..5a4140c6bdbb
--- /dev/null
+++ b/kde-misc/systemd-kcm/files/systemd-kcm-1.2.1-qt-5.11b3.patch
@@ -0,0 +1,36 @@
+From 67246a4a2c52343d2805b597e48a1713b5b9918c Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 17 Jun 2018 22:05:02 +0200
+Subject: [PATCH] Fix build with Qt 5.11.0_beta3 (no more qt5_use_modules)
+
+Reviewers: rthomsen, svuorela
+
+Reviewed By: svuorela
+
+Differential Revision: https://phabricator.kde.org/D13545
+---
+ src/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index ca373fd..d01670a 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -27,6 +27,8 @@ ki18n_wrap_ui(kcmsystemd_SRCS ../ui/kcmsystemd.ui)
+
+ add_library(kcm_systemd MODULE ${kcmsystemd_SRCS})
+ target_link_libraries(kcm_systemd
++ Qt5::Widgets
++ Qt5::DBus
+ KF5::Auth
+ KF5::ConfigWidgets
+ KF5::CoreAddons
+@@ -37,5 +39,3 @@ target_link_libraries(kcm_systemd
+ ${Boost_LIBRARIES}
+ ${JOURNALD_LIBRARIES})
+ install(TARGETS kcm_systemd DESTINATION ${CMAKE_INSTALL_PLUGINDIR})
+-
+-qt5_use_modules(kcm_systemd Widgets DBus)
+--
+2.17.1
+
diff --git a/kde-misc/systemd-kcm/systemd-kcm-1.2.1.ebuild b/kde-misc/systemd-kcm/systemd-kcm-1.2.1.ebuild
index 1fac61ed3d98..b5c491e0a3e9 100644
--- a/kde-misc/systemd-kcm/systemd-kcm-1.2.1.ebuild
+++ b/kde-misc/systemd-kcm/systemd-kcm-1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,10 +27,11 @@ CDEPEND="
sys-apps/systemd
"
DEPEND="${CDEPEND}
- >=dev-libs/boost-1.45
sys-devel/gettext
"
RDEPEND="${CDEPEND}
!kde-misc/kcmsystemd:4
!kde-misc/systemd-kcm:4
"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.11b3.patch" )