summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/catalyst/catalyst-2.0.18-r2.ebuild119
-rw-r--r--dev-util/catalyst/files/catalyst-2.0.18-fix-quotes.patch38
2 files changed, 157 insertions, 0 deletions
diff --git a/dev-util/catalyst/catalyst-2.0.18-r2.ebuild b/dev-util/catalyst/catalyst-2.0.18-r2.ebuild
new file mode 100644
index 000000000000..8405874b349b
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.18-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-2"
+ EGIT_REPO_URI="anongit.gentoo.org/proj/catalyst.git"
+ EGIT_MASTER="master"
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
+ https://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2
+ https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2
+ https://dev.gentoo.org/~dolsen/releases/catalyst/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib python-single-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="https://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache kernel_linux"
+
+DEPEND="
+ app-text/asciidoc
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ app-arch/lbzip2
+ app-crypt/shash
+ app-arch/tar[xattr]
+ virtual/cdrtools
+ amd64? ( >=sys-boot/syslinux-3.72 )
+ ia64? ( sys-fs/dosfstools )
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+ ${PYTHON_DEPS}
+"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+PATCHES=(
+ "${FILESDIR}/catalyst-2.0.18-Do-notuntarwith--acls.patch"
+ "${FILESDIR}/catalyst-2.0.18-fix-quotes.patch"
+)
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+
+ if [[ ${PV} == 3.9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+
+ # Here is where we actually enable ccache
+ use ccache && \
+ sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
+ files/catalyst.conf
+
+ sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ files/catalyst.conf
+
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README AUTHORS
+ doman files/catalyst.1 files/catalyst-spec.5
+
+ python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
+ python_optimize "${ED}"
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "https://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+}
diff --git a/dev-util/catalyst/files/catalyst-2.0.18-fix-quotes.patch b/dev-util/catalyst/files/catalyst-2.0.18-fix-quotes.patch
new file mode 100644
index 000000000000..ccaffbe6b034
--- /dev/null
+++ b/dev-util/catalyst/files/catalyst-2.0.18-fix-quotes.patch
@@ -0,0 +1,38 @@
+From 1eabce3a9c15c5caf022e71c1959e8c8f4819fad Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Thu, 3 Mar 2016 20:48:43 -0500
+Subject: [PATCH] targets/support/chroot-functions.sh: correct quotes to allow
+ expansion of $1
+
+This is a backport of commit b2473eff. The single quotes prevented the proper
+expansion of $1 in setup_pkgmgr(). Since this is usually called as
+`setup_pkgmgr "build"` during stage1 builds, it is surprising this was
+not caught earlier.
+---
+ targets/support/chroot-functions.sh | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/targets/support/chroot-functions.sh b/targets/support/chroot-functions.sh
+index 3b7f77b..6c1a31c 100755
+--- a/targets/support/chroot-functions.sh
++++ b/targets/support/chroot-functions.sh
+@@ -172,12 +172,12 @@ setup_pkgmgr(){
+ # Use --update or portage might just waste time/cycles and reinstall the same version.
+ # Use --newuse to make sure it rebuilds with any changed use flags.
+ if [ -n "$1" ];then
+- echo "Adding USE='${USE} $1' to make.conf for portage build"
+- [ -e /etc/portage/make.conf ] && echo 'USE="${USE} $1"' >> /etc/portage/make.conf
++ echo "Adding USE=\"${USE} $1\" to make.conf for portage build"
++ [ -e /etc/portage/make.conf ] && echo "USE=\"\${USE} $1\"" >> /etc/portage/make.conf
+ run_merge --oneshot --update --newuse sys-apps/portage
+- sed -i '/USE="${USE} $1"/d' /etc/portage/make.conf
++ sed -i "/USE=\"\${USE} $1\"/d" /etc/portage/make.conf
+ else
+- echo "Updating portage with USE='${USE}'"
++ echo "Updating portage with USE=\"${USE}\""
+ run_merge --oneshot --update --newuse sys-apps/portage
+ fi
+ }
+--
+2.4.10
+