summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-2.1.1-fix-yyterror-not-declared.patch16
-rw-r--r--media-sound/linuxsampler/linuxsampler-2.1.1.ebuild3
2 files changed, 18 insertions, 1 deletions
diff --git a/media-sound/linuxsampler/files/linuxsampler-2.1.1-fix-yyterror-not-declared.patch b/media-sound/linuxsampler/files/linuxsampler-2.1.1-fix-yyterror-not-declared.patch
new file mode 100644
index 000000000000..4eb56fddef18
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-2.1.1-fix-yyterror-not-declared.patch
@@ -0,0 +1,16 @@
+--- linuxsampler-2.1.1/src/network/lscp.y 2020/06/07 15:39:31 3786
++++ linuxsampler-2.1.1/src/network/lscp.y 2020/06/08 11:55:18 3787
+@@ -1479,6 +1479,13 @@
+ */
+ typedef std::set< std::vector<YYTYPE_INT16> > YYStackHistory;
+
++/*
++ * YYTERROR macro was removed in Bison 3.6.0, we need it in function below.
++ */
++#ifndef YYTERROR
++# define YYTERROR YYSYMBOL_YYerror
++#endif
++
+ #define DEBUG_BISON_SYNTAX_ERROR_WALKER 0
+
+ /**
diff --git a/media-sound/linuxsampler/linuxsampler-2.1.1.ebuild b/media-sound/linuxsampler/linuxsampler-2.1.1.ebuild
index 3361f3661694..d12a254629bd 100644
--- a/media-sound/linuxsampler/linuxsampler-2.1.1.ebuild
+++ b/media-sound/linuxsampler/linuxsampler-2.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,6 +35,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.0.0-nptl-hardened.patch"
"${FILESDIR}/${PN}-2.0.0-lv2-automagic.patch"
+ "${FILESDIR}/${P}-fix-yyterror-not-declared.patch"
)
DOCS=( AUTHORS ChangeLog NEWS README )