summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/optparse-applicative/Manifest2
-rw-r--r--dev-haskell/optparse-applicative/optparse-applicative-0.16.1.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/optparse-applicative/Manifest b/dev-haskell/optparse-applicative/Manifest
index 5bc87cc48bf0..5e4bf1d83f4f 100644
--- a/dev-haskell/optparse-applicative/Manifest
+++ b/dev-haskell/optparse-applicative/Manifest
@@ -1 +1,3 @@
DIST optparse-applicative-0.15.1.0.tar.gz 56203 BLAKE2B b4db1a96d0dbe1e4f1a4969e5fe1597ca314364bc71da505b9582b8cd0bf0025edc1dea3d1d39b84c108a7b38bea2c53ecd660d1d0b7d44c56b8d18dde14d812 SHA512 e7ab0a2b4812bbfe7802c2d51a45a4f5a5ea162b094631dc6ee4cd79e5def4101ccb04305cfa16942926809ed656f91aa6f68c4d98e93171ca9be99ba40cc51e
+DIST optparse-applicative-0.16.1.0.cabal 4982 BLAKE2B 7e9fed3ff6f09f8b7994d4fd2177ade79e62bc2292dd5fa78bfdf15b0b6f7af0bd696d61ef02ed358460a61f0e2f960d01455091168687f6d2db0b07caf182f6 SHA512 31a1e01b4d0a247c10b1eec2f5bb40e518b447527736b8692846980d182ef2ac4d839b4a24b3d17414fac28700d43d0317deb481c1e0c7ac2b7b38aaafc654a1
+DIST optparse-applicative-0.16.1.0.tar.gz 58315 BLAKE2B 3998ef8594abd3f0f1e85cc44a3efa19d78751f5d17181e1b203504221c219ebf3fa36ccde7351e5821fe1c4a4c0c16a20fffe92259710dbcc7656f4e3a83c50 SHA512 46bdb37b1328a6dbf271dcdb3483266c0c8412fc489e68e32b114745d9cf0108dd49df6cb565df3470121931a769f11996f5fd9fd8e9e38ed6b6853faab56710
diff --git a/dev-haskell/optparse-applicative/optparse-applicative-0.16.1.0.ebuild b/dev-haskell/optparse-applicative/optparse-applicative-0.16.1.0.ebuild
new file mode 100644
index 000000000000..04ff5708ce94
--- /dev/null
+++ b/dev-haskell/optparse-applicative/optparse-applicative-0.16.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+#hackage: flags: +process
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Utilities and combinators for parsing command line options"
+HOMEPAGE="https://github.com/pcapriotti/optparse-applicative"
+HACKAGE_REV="2"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/ansi-wl-pprint-0.6.8:=[profile?] <dev-haskell/ansi-wl-pprint-0.7:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.8:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-2.8 <dev-haskell/quickcheck-2.15 )
+"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=process
+}