summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/gpyutils/Manifest1
-rw-r--r--app-portage/gpyutils/gpyutils-0.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/gpyutils/Manifest b/app-portage/gpyutils/Manifest
index d25ab0be63d3..156fb5ffb1f4 100644
--- a/app-portage/gpyutils/Manifest
+++ b/app-portage/gpyutils/Manifest
@@ -1,2 +1,3 @@
DIST gpyutils-0.2.2.tar.gz 19646 BLAKE2B b5c24817b8a5ef3122d46330d2311a328ffa9c936878f494586ed62fd9fa9d54210c4edcbd9d07f61af7c27faf410e0abf60943188e8340ea52f06d95359c6b1 SHA512 28ca27b3688b593665037bd7a811014a11b3192bc0acc4568c3e70d13cf7a163b41ba3ffd9d8caaaaf4de2758e1cb68b7dcc255d9fb26ca8448a6bfd6416e66e
DIST gpyutils-0.3.tar.gz 19322 BLAKE2B 0b761139f803e1c36d2d9bc8c8e77a8606697a5f872f8eece4bc130657918e639ff82dd275d4553c92a2f1f8a9fe66687e6dce4de40450af435d52fd1ddb91a1 SHA512 2481ccca1390cf65f7a466c7742869977156eebb5d7ab6fe8a421c53dbe1e971e59fce8b4544396fd8682bf9ce73f245d611f2527725cae7253d68ebd2d9b1a2
+DIST gpyutils-0.4.tar.gz 19463 BLAKE2B 4f7a0a474c0c5dcb3afec6ccfb920df17d23eb91aba21765626a791cd7fc533b4165e5aa97df7def2dd5464a2558026378262dbcec48915252ceabb4e37511aa SHA512 02c77cc894adc0e81815777bfeb5f003d74e4b8c54b0f8701c4ada924f09f7f50128d1e842d138f90529f93eef959adac5816d662009bf5e8ca99fe528b35ae0
diff --git a/app-portage/gpyutils/gpyutils-0.4.ebuild b/app-portage/gpyutils/gpyutils-0.4.ebuild
new file mode 100644
index 000000000000..e0e7821fc50b
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://github.com/mgorny/gpyutils/"
+SRC_URI="https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.3.1[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}