summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/requests-credssp/Manifest1
-rw-r--r--dev-python/requests-credssp/metadata.xml12
-rw-r--r--dev-python/requests-credssp/requests-credssp-1.0.2.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/requests-credssp/Manifest b/dev-python/requests-credssp/Manifest
new file mode 100644
index 000000000000..cbbec873d6c3
--- /dev/null
+++ b/dev-python/requests-credssp/Manifest
@@ -0,0 +1 @@
+DIST requests-credssp-1.0.2.tar.gz 21813 BLAKE2B 4626b31e9933e7fe5abdcba59834bedbc14afdd32b21d90124bbb458407213ba8cb92e98394f980f43aacd61de6c0e56e835cf47489ea55338a3dcdd171099e4 SHA512 8a076fc53eee73e24b08f6283b02a48519b9df076222b2e37c145c1d4c1756c29ccc41f0016c5a8ee7f5f7bf76c95fa158016f2cddd42b45a5ab2182939ffae0
diff --git a/dev-python/requests-credssp/metadata.xml b/dev-python/requests-credssp/metadata.xml
new file mode 100644
index 000000000000..5619a58605f2
--- /dev/null
+++ b/dev-python/requests-credssp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">requests-credssp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests-credssp/requests-credssp-1.0.2.ebuild b/dev-python/requests-credssp/requests-credssp-1.0.2.ebuild
new file mode 100644
index 000000000000..be0662bf8c94
--- /dev/null
+++ b/dev-python/requests-credssp/requests-credssp-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="HTTPS CredSSP authentication with the requests library"
+HOMEPAGE="https://pypi.org/project/requests-credssp/"
+SRC_URI="mirror://pypi/r/requests-credssp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ntlm-auth[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"