summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rexml/Manifest1
-rw-r--r--dev-ruby/rexml/rexml-3.2.8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/rexml/Manifest b/dev-ruby/rexml/Manifest
index f3b992c26447..b0f32ca2a9b6 100644
--- a/dev-ruby/rexml/Manifest
+++ b/dev-ruby/rexml/Manifest
@@ -1 +1,2 @@
DIST rexml-3.2.6.tar.gz 459069 BLAKE2B 737b4a8836cae8614bc7a8e579f5c141e3d0e2114a6f6084a186795fa2d0a0008a7cb5d5a8c493b3a4204a901a26c617054ef3b93a7ed845b2f3398f5e25f5ca SHA512 bbf278ed25fbf4d814de9df3cbca691ab43d4e502a02b081e894ce82c161b1931d850df54074ef81c9cb470dca10a81c631da7ccbf908401818fca4c9a4aa5c4
+DIST rexml-3.2.8.tar.gz 460176 BLAKE2B 25b7563c1bc6eacf1b39106fde09c20d34040e5b99d7a38502d4e71cf96fffa08772cdf6def0c50d9e2d116af70a6bd0469aa1dd0512d7c5eca043b9e71979b7 SHA512 255bd834f5c7584a87979a8896fef761ada8d0beb5458cc86b16df59d8634bf1446a0fb679935c003a9a5be7a03ffcb2bf86d08e0f26b0d0f7a3dfbaa87da325
diff --git a/dev-ruby/rexml/rexml-3.2.8.ebuild b/dev-ruby/rexml/rexml-3.2.8.ebuild
new file mode 100644
index 000000000000..2e93e18cce62
--- /dev/null
+++ b/dev-ruby/rexml/rexml-3.2.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An XML toolkit for Ruby"
+HOMEPAGE="https://github.com/ruby/rexml"
+SRC_URI="https://github.com/ruby/rexml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend ">=dev-ruby/strscan-3.0.9"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -i -e 's:require_relative ":require "./:' -e 's/__dir__/"."/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Ensure we use the (new enough) gem version of strscan. The
+ # versions bundled with ruby up to at least 3.3.1 are all too old.
+ sed -e '3igem "strscan"' \
+ -i test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run.rb || die
+}