summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/foomatic-db/Manifest1
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-print/foomatic-db/Manifest b/net-print/foomatic-db/Manifest
index c10f3a1fc1a9..3f1b491a3f3a 100644
--- a/net-print/foomatic-db/Manifest
+++ b/net-print/foomatic-db/Manifest
@@ -1,3 +1,4 @@
DIST foomatic-db-4.0-20170331.tar.xz 5083832 BLAKE2B 3c22869cc50f9e68e04bc9edaf6227764ede1566bf93311f1098d0022174911697a63685488be2c753205e40284ec22c31a64e672fee3851eeec920730b5a344 SHA512 f265a476533a77c27f0eb6414a3b93c6b269effba7bb0d46c9d3965c0e7218c3b081ae5e3f01ebfe7afbec70379543dd2e553b97b338eca43c34c11a4ffb4dcc
DIST foomatic-db-4.0-20180126.tar.xz 5418608 BLAKE2B e11dbfc7e4cf121ba8b456820438b0418981c414c6a798dee463430dd8ccf65b424e1d597bc21b32929e858d0282b12df81fb419793bd34172b0c414619d2762 SHA512 1879e2601ad88262c99201bff5353ac40516985de72dd894eeeae2589ae2b82dd4dbfc972cb3ff43f209efb92753d4ed0ce584d89cd242fedc011511c45d8a87
DIST foomatic-db-4.0-20190225.tar.xz 6436584 BLAKE2B ee3c0cddb6bf1d4e4a41511abbddd14bc92df3e67c298c93b1f83aa2d8922ce3e8f2d4075c732c71c264c92d1542d5eee10ca16033c98a54c4cfd2c694a1e4d9 SHA512 2e49b3f20e149136e522b7845d781e8bd858f7b9239ba8036290f3d03422a112878f9edea1dfc75365a326d794aaca796496871469169a51ff2084aaef6ea1da
+DIST foomatic-db-4.0-20190226.tar.xz 6438248 BLAKE2B c5ce6b3ec5a29524f6f8c73fdaec88a97a3fd4521753c5058d470ebadf7c35c3218bd7e78023a26b267796ccfbca98368ee4d4bc5252b9339ee1c067adbe80b2 SHA512 308cf8b5648ae8f3be1a1a5af1885319ae9f263575e7b0b06bd66e6e3e0b495656124face65e285bfa657dbff3cff226bb00d78b873f16849b426641dc7d52fe
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild
new file mode 100644
index 000000000000..0eb0def17b86
--- /dev/null
+++ b/net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ net-print/foomatic-db-engine
+ !net-print/foo2zjs[hp2600n]"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ # ppd files do not belong to this package
+ rm -r db/source/PPD || die
+ default
+}
+
+src_configure() {
+ econf \
+ --disable-gzip-ppds \
+ --disable-ppds-to-cups
+}
+
+src_install() {
+ default
+ rmdir "${ED}"/usr/share/foomatic/db/source/PPD || die
+ # Avoid collision with foo2zjs, bug 185486
+ rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml} || die
+}