summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/gnome-calculator/Manifest1
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.30.0.ebuild48
-rw-r--r--gnome-extra/gnome-calculator/metadata.xml4
3 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calculator/Manifest b/gnome-extra/gnome-calculator/Manifest
index 18a95e3e9131..2ea1a98fb3b6 100644
--- a/gnome-extra/gnome-calculator/Manifest
+++ b/gnome-extra/gnome-calculator/Manifest
@@ -1 +1,2 @@
DIST gnome-calculator-3.24.0.tar.xz 1358368 BLAKE2B 81ad42598418b11f2436ebf482bbf93547460990cdb464efb3107e93010081f3d687bf99c80d35d9a6576b5d838218c7ea07e81256abfa358ce78031d80b346d SHA512 55968f3a307748050089652394a3652b8e199be9abf87d43e732874526dc2f08c4521e302a69afd2c09705ffa67a890fc2217503dd31ef51959df9189364c22f
+DIST gnome-calculator-3.30.0.tar.xz 1069768 BLAKE2B c59848760da90f76648b8de888bd41319bc077eeabe729792142aa36ca634b439ab1d4a07318afaa335e511d5bc68937cca4aa7ce63c331064d809c8d4880283 SHA512 16d99c1919614bef4ce4e056543e369563c7ac773e77f3a9e5a09eaddd33f18077b2ba287b1a925ad39f6832236de7f7924dc7a76621ace7b02412d0166df0c2
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.30.0.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.30.0.ebuild
new file mode 100644
index 000000000000..54fc94cc7069
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.30.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+# gtksourceview vapi definitions in dev-lang/vala itself are too old, and newer vala removes them
+# altogether, thus we need them installed by gtksourceview[vala]
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=x11-libs/gtk+-3.19.3:3
+ >=x11-libs/gtksourceview-3.15.1:3.0[vala]
+ >=net-libs/libsoup-2.42:2.4
+ dev-libs/libxml2:2
+ dev-libs/mpc:=
+ dev-libs/mpfr:0=
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-calculator/metadata.xml b/gnome-extra/gnome-calculator/metadata.xml
index 39980802b1da..422f1444573a 100644
--- a/gnome-extra/gnome-calculator/metadata.xml
+++ b/gnome-extra/gnome-calculator/metadata.xml
@@ -5,4 +5,8 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+<longdescription lang="en">
+ GNOME Calculator is an application that solves mathematical equations and is
+ suitable as a default application in a Desktop environment.
+</longdescription>
</pkgmetadata>