summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/uriparser/files/uriparser-0.8.4-doc-install.patch13
-rw-r--r--dev-libs/uriparser/uriparser-0.8.4-r1.ebuild52
-rw-r--r--dev-libs/uriparser/uriparser-0.8.4.ebuild12
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-libs/uriparser/files/uriparser-0.8.4-doc-install.patch b/dev-libs/uriparser/files/uriparser-0.8.4-doc-install.patch
new file mode 100644
index 000000000000..28cef94c6423
--- /dev/null
+++ b/dev-libs/uriparser/files/uriparser-0.8.4-doc-install.patch
@@ -0,0 +1,13 @@
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index ae5e101..012f0bc 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -24,7 +24,7 @@ distclean-local:
+ ## Install doc files
+ install-data-local:
+ $(MKDIR_P) "$(DESTDIR)$(docdir)/html/search" ## Didn't work with installdirs-local
+- $(INSTALL_DATA) html/*.css html/*.html html/*.js html/*.map html/*.md5 html/*.png "$(DESTDIR)$(docdir)/html/"
++ $(INSTALL_DATA) html/*.css html/*.html html/*.js html/*.md5 html/*.png "$(DESTDIR)$(docdir)/html/"
+ $(INSTALL_DATA) html/search/* "$(DESTDIR)$(docdir)/html/search/"
+ -$(INSTALL_DATA) *.qch "$(DESTDIR)$(docdir)/"
+
diff --git a/dev-libs/uriparser/uriparser-0.8.4-r1.ebuild b/dev-libs/uriparser/uriparser-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..84b47476abda
--- /dev/null
+++ b/dev-libs/uriparser/uriparser-0.8.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
+HOMEPAGE="http://uriparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc qt5 test unicode"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.5.8
+ qt5? ( dev-qt/qthelp:5 ) )
+ test? ( >=dev-util/cpptest-1.1.1 )"
+
+REQUIRED_USE="test? ( unicode )"
+
+PATCHES=( "${FILESDIR}"/${P}-doc-install.patch )
+
+DOCS=( AUTHORS ChangeLog THANKS )
+
+src_prepare() {
+ default
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-sizedown \
+ $(use_enable test) \
+ --enable-char \
+ $(use_enable unicode wchar_t) \
+ $(use_enable doc) \
+ --docdir=/usr/share/doc/${PF}/
+}
+
+src_install() {
+ default
+
+ if use doc && use qt5; then
+ dodoc doc/*.qch
+ docompress -x /usr/share/doc/${PF}/${P}.qch
+ fi
+}
diff --git a/dev-libs/uriparser/uriparser-0.8.4.ebuild b/dev-libs/uriparser/uriparser-0.8.4.ebuild
index 97ad9a716173..11c9e1d59348 100644
--- a/dev-libs/uriparser/uriparser-0.8.4.ebuild
+++ b/dev-libs/uriparser/uriparser-0.8.4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+inherit epatch autotools
+
DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
HOMEPAGE="http://uriparser.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -20,6 +22,14 @@ DEPEND="virtual/pkgconfig
REQUIRED_USE="test? ( unicode )"
+PATCHES=( "${FILESDIR}"/${P}-doc-install.patch )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ epatch_user
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-sizedown \