summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/subliminal/Manifest1
-rw-r--r--media-video/subliminal/subliminal-1.1.1-r1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-video/subliminal/Manifest b/media-video/subliminal/Manifest
index 9d67508705ae..3f963e7fc4af 100644
--- a/media-video/subliminal/Manifest
+++ b/media-video/subliminal/Manifest
@@ -1 +1,2 @@
+DIST subliminal-1.1.1-r1.tar.gz 4117531 SHA256 fd02eec1206ab1ef0ce83b0e051b3e029d90348f7a06461b9b6cdc681cea7de6 SHA512 b00bb34def5982041b6eec1acba84b0c297ea1b909dc0b9fe7c290c20f0b00e17e19a847987f549a07e5edfe0fee92913f00396cb8abe26c1f86927e027bccf1 WHIRLPOOL 0d95103c6cca1d50d05b3cf3ae113fadf0a294569cac9e55c549357d16f7c77ce408e3914e2a2b9e3a837659924bd1ff47db4f3459c42b4892b823d0fcf87cce
DIST subliminal-1.1.1.tar.gz 37871 SHA256 ab50cff2dcdc4c302f11074d22b2aa8b1c12bbd13e81ee7ad362947a18ad3fca SHA512 00f86944daf1054ac57cf90ea34d5d898fd25f9dbf0cecaf5fba7f3a3f8e63e20edb18d62f7a48403a4478c3df5f344c642e82f7e6bcf49625a867164dc7193a WHIRLPOOL 4d1adb859f32c14bce9ef874dc1cd5fd4981cb2d9379dc2ecab9c5198eda667379aff965b21b2b2c6a69c5a320d687f3345d8f37e41e0524c0b609e175b2a792
diff --git a/media-video/subliminal/subliminal-1.1.1-r1.ebuild b/media-video/subliminal/subliminal-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..1fdb78bf7c65
--- /dev/null
+++ b/media-video/subliminal/subliminal-1.1.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to search and download subtitles"
+HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.python.org/pypi/subliminal"
+SRC_URI="https://github.com/Diaoul/${PN}/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/guessit-0.9.1[${PYTHON_USEDEP}]
+ <dev-python/guessit-2[${PYTHON_USEDEP}]
+ >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.2.0:4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+# Tests require network.
+RESTRICT=test
+
+python_prepare_all() {
+ # Disable code checkers as they require unavailable dependencies.
+ sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
+ sed -i -e "s/'pytest-\(pep8\|flakes\)',//g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}