summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-base/xcb-proto/Manifest1
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.14.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index f69c09e1b895..8b326f7f04ec 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1 +1,2 @@
DIST xcb-proto-1.13.tar.bz2 151981 BLAKE2B 04d90838f8a892103e6d7aa807f1b0b6794f1538c6c986ad3cba67cff3a963ff680e45c2137c5d6330736a3aa1a387d61fc247f23487de9dada2f4013590b4a1 SHA512 002aa2aa0ad503977e03419c6f136f1e3aa8c787916830ce6d6be8f81ca99edc1d8fc5f71ce8c592b490cc767bf6567695f0bafe55fe3f743076bcddbaac07f7
+DIST xcb-proto-1.14.tar.xz 143384 BLAKE2B 60212b0f0ce039a64a2e6cbbc78564eeffc57cff20987b37dc780d8d97ae888a7dbfbbaadc6e0e4bedfc5d1e360f16318e3825ad8406de668d9c7c66cf7f4b5d SHA512 de66d568163b6da2be9d6c59984f3afa3acd119a781378638045fd68018665ef5c9af98f024e9962ba3eb7c7a4d85c27ba70ffafceb2324ccc6940f34de16690
diff --git a/x11-base/xcb-proto/xcb-proto-1.14.ebuild b/x11-base/xcb-proto/xcb-proto-1.14.ebuild
new file mode 100644
index 000000000000..1d2fe92f1d17
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+XORG_MULTILIB=yes
+XORG_STATIC=no
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
+ python_foreach_impl python_optimize
+ fi
+}