summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-libs/wf-config/Manifest1
-rw-r--r--gui-libs/wf-config/wf-config-0.8.0.ebuild44
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild6
3 files changed, 49 insertions, 2 deletions
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
index 15f9e410c096..1959ca230d3e 100644
--- a/gui-libs/wf-config/Manifest
+++ b/gui-libs/wf-config/Manifest
@@ -1 +1,2 @@
DIST wf-config-0.7.1.tar.xz 39120 BLAKE2B b18048334df12b002391fe4a74529cb61df76a0678c9052f8ac91d777e8a48dae46b87680fb44630ebfb9a350dbac36b15bc81850341fa4cd6299c12f6fa057d SHA512 d535a09a3465a54a607df7b8764ee6818ab8b83536d68c85167b282b95a176636e4bf5cda6c0d1638c07721a1f4208203e9d41b83675038fb590a535314df719
+DIST wf-config-0.8.0.tar.xz 41200 BLAKE2B d56cd04c18c2cd8c0bac86493ad662244bde0e9cce1caf81d0fff34d9f2df2470c1aa8c95fead9e91dd5793d570b01dc6ef99b1986b8658b06ef93156a1526f8 SHA512 79cca2429a39ee81f853043698c57fc08025634926773253cff73fc564dcf203335b4b861d82b60a769bbab7b07be6a7e181c9ea29ad98ce930de20f9723893f
diff --git a/gui-libs/wf-config/wf-config-0.8.0.ebuild b/gui-libs/wf-config/wf-config-0.8.0.ebuild
new file mode 100644
index 000000000000..4e970b7ae0aa
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ media-libs/glm
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+ test? ( dev-cpp/doctest )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test tests)
+ -Dlocale_test=false # requires de_DE locale to be installed
+ )
+
+ meson_src_configure
+}
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
index ae9b12db688b..4e970b7ae0aa 100644
--- a/gui-libs/wf-config/wf-config-9999.ebuild
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -11,13 +11,14 @@ HOMEPAGE="https://github.com/WayfireWM/wf-config"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -36,6 +37,7 @@ BDEPEND="
src_configure() {
local emesonargs=(
$(meson_feature test tests)
+ -Dlocale_test=false # requires de_DE locale to be installed
)
meson_src_configure