summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/cryptohash-sha1/Manifest1
-rw-r--r--dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild38
-rw-r--r--dev-haskell/cryptohash-sha1/metadata.xml24
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-sha1/Manifest b/dev-haskell/cryptohash-sha1/Manifest
new file mode 100644
index 000000000000..763430616331
--- /dev/null
+++ b/dev-haskell/cryptohash-sha1/Manifest
@@ -0,0 +1 @@
+DIST cryptohash-sha1-0.11.100.1.tar.gz 10198 BLAKE2B 5d9835feeb43a80c83de0e390d59efc908fd538ed4146ace4eb0cd67392503cf414a2324968e8249f2b506978348caa6e92c70e82c52eaa7ac14e3956388f05e SHA512 e3528c70501ffaf4649adc0fe120a0b333329761fa66505083269afa67828c16695fd91567035adef0b77915df47a6bcc99d2d90f0ecb26eda583829261cb1bc
diff --git a/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild b/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild
new file mode 100644
index 000000000000..c53c2bcf8aa6
--- /dev/null
+++ b/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-1 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha1"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.10' 'base >= 4.5' \
+ 'tasty == 0.11.*' 'tasty >= 0.11' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
+ default
+}
diff --git a/dev-haskell/cryptohash-sha1/metadata.xml b/dev-haskell/cryptohash-sha1/metadata.xml
new file mode 100644
index 000000000000..6967df1105e8
--- /dev/null
+++ b/dev-haskell/cryptohash-sha1/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A practical incremental and one-pass, pure API to the
+ &lt;https://en.wikipedia.org/wiki/SHA-1 SHA-1 hash algorithm&gt;
+ (including &lt;https://en.wikipedia.org/wiki/HMAC HMAC&gt; support)
+ with performance close to the fastest implementations available in other languages.
+
+ The implementation is made in C with a haskell FFI wrapper that hides the C implementation.
+
+ NOTE: This package has been forked off @cryptohash-0.11.7@ because the @cryptohash@ package has been
+ deprecated and so this package continues to satisfy the need for a lightweight package
+ providing the SHA1 hash algorithm without any dependencies on packages other than
+ @base@ and @bytestring@.
+
+ Consequently, this package can be used as a drop-in replacement for @cryptohash@&#39;s
+ &quot;Crypto.Hash.SHA1&quot; module, though with a clearly smaller footprint.
+ </longdescription>
+</pkgmetadata>