summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/libint/libint-1.1.6.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/sci-libs/libint/libint-1.1.6.ebuild b/sci-libs/libint/libint-1.1.6.ebuild
index 760d266a7811..f3a93eaaacdf 100644
--- a/sci-libs/libint/libint-1.1.6.ebuild
+++ b/sci-libs/libint/libint-1.1.6.ebuild
@@ -1,20 +1,17 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils fortran-2 toolchain-funcs versionator
-
-MY_PV="$(replace_all_version_separators -)"
+MY_PV="$(ver_rs 0- -)"
+inherit autotools fortran-2 toolchain-funcs
DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
HOMEPAGE="https://github.com/evaleev/libint"
SRC_URI="https://github.com/evaleev/libint/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
-SLOT="1"
LICENSE="GPL-2"
+SLOT="1"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
@@ -24,7 +21,8 @@ PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
src_prepare() {
mv configure.{in,ac} || die
- autotools-utils_src_prepare
+ default
+ eautoreconf
}
src_configure() {
@@ -36,5 +34,5 @@ src_configure() {
--with-cc-optflags="${CFLAGS}"
--with-cxx-optflags="${CXXFLAGS}"
)
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
}