summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash-completion/bash-completion-2.11.ebuild7
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/app-shells/bash-completion/bash-completion-2.11.ebuild b/app-shells/bash-completion/bash-completion-2.11.ebuild
index 36c924cea3a5..4c55e7352304 100644
--- a/app-shells/bash-completion/bash-completion-2.11.ebuild
+++ b/app-shells/bash-completion/bash-completion-2.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -89,7 +89,10 @@ src_prepare() {
src_test() {
# portage's HOME override breaks tests
- emake check HOME="$(egethome "${UID}")" PYTESTFLAGS="-vv" NETWORK=none
+ local myhome=$(unset HOME; echo ~)
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict "${myhome}"
+ emake check HOME="${myhome}" PYTESTFLAGS="-vv" NETWORK=none
}
src_install() {
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 70ce84b4ed82..2f4caf5b89e1 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -99,7 +99,10 @@ src_prepare() {
src_test() {
# portage's HOME override breaks tests
- emake check HOME="$(egethome "${UID}")" PYTESTFLAGS="-vv" NETWORK=none
+ local myhome=$(unset HOME; echo ~)
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict "${myhome}"
+ emake check HOME="${myhome}" PYTESTFLAGS="-vv" NETWORK=none
}
src_install() {