summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jeepney/Manifest1
-rw-r--r--dev-python/jeepney/jeepney-0.7.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/jeepney/Manifest b/dev-python/jeepney/Manifest
index a37ec86c12fd..3f6b633029d9 100644
--- a/dev-python/jeepney/Manifest
+++ b/dev-python/jeepney/Manifest
@@ -1,2 +1,3 @@
DIST jeepney-0.6.0.tar.gz 49513 BLAKE2B e5f9b5104cf07dbcd2d40c2d22b690dfd56c456ab56daf44f4abee83f0bfe7e1dfbad797348044d51e3dc20fbc6ce68bf8df54f9c1e46d7a86ceb22d3ab30f8d SHA512 140be9dd28ed853d2d41b6a8bbeb2f22c0270ce7bf33b943ec2ac010db17d4f06e253fa8637fbbb3044fe9ffdbfa1e15f0c663eb44bdd538f8c47c2e7dab3ca5
DIST jeepney-0.7.0.tar.gz 61236 BLAKE2B ec477ed0d96d7d82a256c7f62900eff0282ebec4545e30807fd62cffb419ed763fd8042bdd4d72c6cf43ac09d24af9cd86797b1baec61ad5965e51b3d669175d SHA512 b1fac480da0d8798b28eae30cb22ee97d4f73a11922f7b1bce86eebf938c2980414c2d026ef5a1cdcd95813724873700d348b04ba337aaac0706b2c8b38ea6c2
+DIST jeepney-0.7.1.tar.gz 61833 BLAKE2B 626d4c921d0548ea898197ac5459f20b4c73fd52d3579c5b74f257158c82803011655c1d418d7d10afe8ba803100530bc08dbcce41e12727888de5be5995adb3 SHA512 f0af5a18a669f1a6322925201cad83ee01bc5a1b91577565042fd8a18b506a3650ff67b0ba333c8fb3b179f43ef243d16b07a9a1f7a7e5baec825dda0e6b0571
diff --git a/dev-python/jeepney/jeepney-0.7.1.ebuild b/dev-python/jeepney/jeepney-0.7.1.ebuild
new file mode 100644
index 000000000000..e68d7065e154
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ $(python_gen_cond_dep '
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local ignore=()
+ # keep in sync with python_gen_cond_dep!
+ if ! has "${EPYTHON}" python3.{8..9}; then
+ ignore+=( jeepney/io/tests/test_trio.py )
+ fi
+
+ dbus-run-session pytest -vv -ra -l ${ignore[@]/#/--ignore } ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}