summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/sonarr/Manifest5
-rw-r--r--www-apps/sonarr/sonarr-4.0.1.987.ebuild65
2 files changed, 70 insertions, 0 deletions
diff --git a/www-apps/sonarr/Manifest b/www-apps/sonarr/Manifest
index 5358f4e097a8..9c655303737d 100644
--- a/www-apps/sonarr/Manifest
+++ b/www-apps/sonarr/Manifest
@@ -3,3 +3,8 @@ DIST Sonarr.develop.4.0.1.953.linux-arm64.tar.gz 93018868 BLAKE2B 77b2a93b9db360
DIST Sonarr.develop.4.0.1.953.linux-musl-arm64.tar.gz 93075074 BLAKE2B e864ebabb17c4092b3a260e0305c584be0df4ef41b8f0e3e1763189ce4491f896c4a096327c8a60ffc27b84e842b7619c5207dfae37cffcf49b2ff6858b23c98 SHA512 1f189d2dca625c0ae8b6e85dac680c6ceb6b5216e1fa72f58f4d60339bf5cb103536927139605861b5d922fdafaceeab95d3f21511d1f699a5aa3e71352e1965
DIST Sonarr.develop.4.0.1.953.linux-musl-x64.tar.gz 98003389 BLAKE2B f8304a6c6cb9e27f6869845e978953d6b26a13287f69a9cf069ce678b8a994a452b4b631a5cddc7dd6c622701360681cb8382dbe607b6d9968f91bd39bd4b7fd SHA512 0d3c036f87004220cf1c67dd921d92230b1e35f5e26d243b36986bcd599063a98506804e7d99fd719265040576fce06f12e727346bac673930a305302f7ac1b7
DIST Sonarr.develop.4.0.1.953.linux-x64.tar.gz 98938223 BLAKE2B 2977d9d71311dde024f236fd1ba167fc030da7518dce351a6c09bd5924488ebd760e7458796e7c5eaa1aa27d1f90d0cd0ccdf87b16b3525def0e943f091cefac SHA512 74fc0cad28d874c8e678a38641f3fe01a0fdb2678aa3008081744c7327d1a762229157e8e9b952a168bdbaae4f42e92e5e0a77a7f4ee736877562d066a5e868a
+DIST Sonarr.develop.4.0.1.987.linux-arm.tar.gz 93285783 BLAKE2B 87d60e3b6cdf95984495ade19f16791880b7253a2f2b4f7cae906ec03272460b34abfc773e6bc8516616319cbaee71776419671556c611822c444587a613fcd6 SHA512 e029ff957ae9b2f14db7931f706fd812cefcfa160b66a0e8168ac337ad7340a6890f85a45ddede7ad4a42c2de0ddd79c33ca1d7f7c98458711b2c1e5722ecc77
+DIST Sonarr.develop.4.0.1.987.linux-arm64.tar.gz 93017124 BLAKE2B ee4187df0d948651dd127390e647a95986d537b4c6b22933e51da1c0f83ac957bb65106df48eb07d9270c07bb63739adc24d8255545995e5868b37613462b849 SHA512 e9c0f1d886eae3b37c638b653d3b72459459b1a967948be8951df5f7349dcf8080d700ded406be83e5979d29801a2257e287d1cc8e6dc0e82fe02effb0906a87
+DIST Sonarr.develop.4.0.1.987.linux-musl-arm64.tar.gz 93087801 BLAKE2B 406018f2f2f4a3bb7fa8cba71d9ea7f0659755e390f403339b64d0c2ae869fba20fb644724f896ba2145d8824e7648a816e604cd07318eba29f34b8449d29178 SHA512 11b61b65afdfeb897f1e80fea8316d87c9af7ca104fd3841c8fd31dc36697af45a5a46f9fd6efc0ad9754652c476ca6f5b125f2975f79a29fbe6530c88b1409e
+DIST Sonarr.develop.4.0.1.987.linux-musl-x64.tar.gz 98001687 BLAKE2B 5debec73eb7c6be6d9aa53180a301443516b77b25778158c5ce826c676db501ffb1921df2281281fd6130701768c52a735fecdac0d5657d031566ed50fa882d4 SHA512 3e7705bde6a23f626c507e08a109bfa1a2275250423a31369c16c74c070aa43d2c792b2899bf0d87284d25265b91e0191befdc3fc2744510ef0f661a829549c2
+DIST Sonarr.develop.4.0.1.987.linux-x64.tar.gz 98949901 BLAKE2B 5616c15a8ede21c0eda6cbebe9f13cf4d69808006bba6b54ff8fc22091e737736760a550b1d0dd3a5c1e9b7c6d884ffc001ece6fac86cc006514f3555b4358df SHA512 b2d1a0edbb0e977f58bf40470a7b2d2603e89049c23325ea2c61f75ac2dc31a3c92230f94848fd8db89bb3efb518fc6b3527b0b2017e0edad0d9c1248c87825c
diff --git a/www-apps/sonarr/sonarr-4.0.1.987.ebuild b/www-apps/sonarr/sonarr-4.0.1.987.ebuild
new file mode 100644
index 000000000000..96ad64a73d0b
--- /dev/null
+++ b/www-apps/sonarr/sonarr-4.0.1.987.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+SRC_URI="
+ amd64? (
+ elibc_glibc? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-x64.tar.gz )
+ elibc_musl? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-x64.tar.gz )
+ )
+ arm? (
+ elibc_glibc? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm.tar.gz )
+ )
+ arm64? (
+ elibc_glibc? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm64.tar.gz )
+ elibc_musl? ( https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-arm64.tar.gz )
+ )
+"
+
+DESCRIPTION="Sonarr is a Smart PVR for newsgroup and bittorrent users"
+HOMEPAGE="https://www.sonarr.tv"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/sonarr
+ acct-user/sonarr
+ media-video/mediainfo
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}/Sonarr"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Sonarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/${PN}.init-r2" ${PN}
+
+ keepdir /var/lib/${PN}
+ fowners -R ${PN}:${PN} /var/lib/${PN}
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ dodir "/opt/${PN}"
+ cp -R "${S}/." "${D}/opt/sonarr" || die "Install failed!"
+
+ systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
+ systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}@.service"
+}