summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/urlwatch-2.16.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 41a574f404f5..eb52709f17bd 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,3 +1,4 @@
DIST urlwatch-2.13.tar.gz 34312 BLAKE2B 6ac618d4f1f78b0a3f6d17dd2283704e8d1fc7173ce6d79fcf0f9177f48463a610a4c20d8483a4a9c22e56eca67730ef25982981f310ca8e9927e48e298a1b1d SHA512 5ca6ad3de54c2e1d63cb545ae0d213a4483ef175dad947be00994bc990d047c7aec1f3b0a8b23290672db940001a9cc31c919aa7d9c280ab4792299e2dba684c
DIST urlwatch-2.14.tar.gz 36587 BLAKE2B 6c4115c58cc9aae5ac8c62f7cb360ca38afa9a9ceadc93f3c9d2bccc7808ab1accf912a0f5756d984bb7a33fa448c91c1bb90e841bd45e2f8d34c4d74cae531c SHA512 8c7b479f80973da28e281e8437a30038c6dcdf9036c30cb5e685fdb9460fbb7b90a27e9d5a27290cfe30de1a0f443644b13c8a10740c205ebd58bcb2bb29c888
DIST urlwatch-2.15.tar.gz 36839 BLAKE2B a474d93adb4ef95ad5c44b7cee4a077dd744caf09c84ec64b2e9f04635505a8ffd422f4ba56cb2069571b5b4b1e1f7df4b7412a716b5738388a0c55ea831e050 SHA512 3390a693656a89e75836f713249261650c03e1dc1d1819d82872d35eead7f29844502073d8674e92e97a32e44180347928e5dfada814798984d11e1ff4f0ac40
+DIST urlwatch-2.16.tar.gz 42713 BLAKE2B bee95c808b8705135112646ed7bf42c6606d716f447394e69fbc3355d38597e44b3e94ac91c6c2304fadcc5eb7d35349e6d54601721319c39268583fa8c7c042 SHA512 ffa9245bc4b8631e3105b1afd4ed3c3f5585bc30cd56c7531f9c2d0e4d61e36b56db3a69d62f851bed5fba9c9c332034b1757d70b32f4a4b0607ae59ed6cf887
diff --git a/www-misc/urlwatch/urlwatch-2.16.ebuild b/www-misc/urlwatch/urlwatch-2.16.ebuild
new file mode 100644
index 000000000000..be9149902a11
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+python_test() {
+ nosetests -v test || die "tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup:4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}