summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-redis/Manifest1
-rw-r--r--dev-php/pecl-redis/pecl-redis-3.1.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index 97fb3a92e0a8..2b719d3ed280 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1,2 +1,3 @@
DIST redis-2.2.7.tgz 134340 SHA256 95e5331cd7e709771eb4479c455bcf326a74b2aea3b1a5cba00b4c95e66dc902 SHA512 88be2abeda62b7c1c95b6d399bbb5f97774d956001b4d13a8e5f183e86fe6336d91f479a8125adcaeff1ad5617a920953961360fc3484ebafc3ed915bcd7f86c WHIRLPOOL e7c8ea7c0c4578933211d4571d742ad09eadb5dd93e207d4f0d5858bfacb7a78eb4bd7ed34cafbc17b465b0d423ea0ff788dee907d89c4939ee4a9acbbe8b95d
+DIST redis-3.1.1.tgz 198597 SHA256 aa1a30f2c5e1f532289b9b90af71b42db86bb85e9f8c344a455a4312c79d917e SHA512 a9bf74342dbaec518623f99a958130d61ae643111448dd16c974fcf96ec722d34c1f7d2e7b09e786abe7432bff1d34e2d8bd895c8b6c5f9b88faac701eb77b2a WHIRLPOOL 1053247b933a7f0bc2d6d79f981e0745e1d6db094fc9d4588a1e23e9670bdfabeb53ac5cae5ddf70ee8544df02dac0435f9339612e04e174055529670b705c07
DIST redis-3.1.1RC2.tgz 198513 SHA256 21dc974d12ed707c2dce34b268eb3411338961cd4c849325e7c28a587f137efe SHA512 8c008d3549347c56c6e0226967da387a93f7f6ca32071c45487fecc072fc09cf71d901ef26a871a510cf4b1bbe6d7a0ab5341691f9510b1bbd5e7dc067b08272 WHIRLPOOL ee68ce66a2ba40723c3be6e95b58d69ed11fe26b8e68abf14eda72b3044edd34d4a01c27950865246f04602aa3d0223351a92774d7ccb0a98d3f1897a3680695
diff --git a/dev-php/pecl-redis/pecl-redis-3.1.1.ebuild b/dev-php/pecl-redis/pecl-redis-3.1.1.ebuild
new file mode 100644
index 000000000000..c6d5ee8620e2
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-3.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="redis"
+USE_PHP="php5-6 php7-0 php7-1"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="igbinary +session"
+
+DEPEND="igbinary? (
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] )
+ php_targets_php7-0? ( dev-php/igbinary[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/igbinary[php_targets_php7-1] ) )"
+RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable session redis-session)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test(){
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}