summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/bbswitch/bbswitch-0.8-r1.ebuild54
-rw-r--r--sys-power/bbswitch/bbswitch-0.8.ebuild42
2 files changed, 0 insertions, 96 deletions
diff --git a/sys-power/bbswitch/bbswitch-0.8-r1.ebuild b/sys-power/bbswitch/bbswitch-0.8-r1.ebuild
deleted file mode 100644
index d2d37a055f8a..000000000000
--- a/sys-power/bbswitch/bbswitch-0.8-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-mod
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Bumblebee-Project/${PN}.git"
- EGIT_BRANCH="develop"
-else
- PATCHES=( "${FILESDIR}/${PN}-0.8-kernel-4.12.patch" )
- SRC_URI="https://github.com/Bumblebee-Project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
-HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
-
-SLOT="0"
-LICENSE="GPL-3+"
-IUSE=""
-
-DEPEND="
- virtual/linux-sources
- sys-kernel/linux-headers
-"
-RDEPEND=""
-
-MODULE_NAMES="bbswitch(acpi)"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- BUILD_TARGETS="default"
- BUILD_PARAMS="KVERSION=${KV_FULL}"
-}
-
-src_prepare() {
- # Fix build failure, bug #513542
- sed -i 's/^KDIR.*$/KDIR\ \:= \/usr\/src\/linux/g' Makefile || die
-
- default
-}
-
-src_install() {
- einstalldocs
-
- insinto /etc/modprobe.d
- newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
-
- linux-mod_src_install
-}
diff --git a/sys-power/bbswitch/bbswitch-0.8.ebuild b/sys-power/bbswitch/bbswitch-0.8.ebuild
deleted file mode 100644
index 6d3bf202702a..000000000000
--- a/sys-power/bbswitch/bbswitch-0.8.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils linux-mod
-
-DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
-HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
-SRC_URI="https://github.com/Bumblebee-Project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3+"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="
- virtual/linux-sources
- sys-kernel/linux-headers
-"
-RDEPEND=""
-
-MODULE_NAMES="bbswitch(acpi)"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- BUILD_TARGETS="default"
- BUILD_PARAMS="KVERSION=${KV_FULL}"
-}
-
-src_prepare() {
- # Fix build failure, bug #513542
- sed -i 's/^KDIR.*$/KDIR\ \:= \/usr\/src\/linux/g' Makefile || die
-}
-
-src_install() {
- insinto /etc/modprobe.d
- newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
- dodoc NEWS README.md
-
- linux-mod_src_install
-}